Does everyone using AD software installation enable computer configuration \ Administrative Templates \ System \ Logon \ always wait for the network at computer startup and logon. For us it's not configured or disabled which means that group policy is applied asynchrously in the background which can result in two restarts for software installations. I understand if this policy is enabled group policy is applied in the foreground synchronously and the computer and user policies will be applied prior to the user logging in resulting in one restart software installations. What everyone doin w/this one?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
hey skis' - ours is whatever the default is and have never changed it - but as we had a previous post going on the topic, is this to check your software installs are working correctly?

Policies are updated every 90 minutes in the background or at reboot, so maybe why you're rebooting twice because a general background refresh hasn't occured. When i'm testing a GPO update on a client i'll run this command

gpupdate /force

to force a policy update and then either log off/on again or reboot when prompted.
Answered 03/05/2010 by: squeakstar
Orange Senior Belt

Please log in to comment
0
Squeakstar,
Software installs are going well. This thread is in regards to Warning event: 108 and event 101 Source: Application Mangement in the application log.

Event 108 reports Failed to apply changes to software installation settings. Software installation policy application has been delayed until the next logon because an administrator has enabled logon optimization for group policy. The error was: The group policy framework should call the extension in the sychronous foreground policy refresh.

Event 101 reports The assignement of application "XXXXXXXXXX" from policy "XXXXXXXXXX" failed. The error was: The group policy framework should call the extension in the synchronous foreground policy refresh.

You see if computer configuration \ Administrative Templates \ System \ Logon \ always wait for the network at computer startup and logon is not configured which it is by default, Fast user logon is enabled which logs the user on with cashed credentials then applies computer policy. In turn the install is delayed until the next reboot.

Almost all of our installs are upgrades driven by exploited web apps and it makes sense to enable the policy to ensure the PC is updated on the next restart.

If you comb the event logs I think you may find these.

Does anyone have the policy enable?
Answered 03/09/2010 by: skislowski
Senior Yellow Belt

Please log in to comment
0
Hey - i went had a nosey on our server just to compare what you have set-up with ours. Our network too would need two restarts if i just expected the machines to reboot straight after the policy had been applied - but generally they don't as they've been on most of the day, they've had a background refresh and will kick in the policy on next reboot...

As far as your Event ID 108, here's a link to a few possible solutions http://www.eventid.net/display.asp?eventid=108&eventno=1181&source=Application Management&phase=1

things to check being you've pointed to the application installers via UNC / the directory your deploying from has the correct permissions / and you've the latest msi 3.1 installed. If you've got the correct permissions at the root of the folder try forcing a trickle down of permissions tomake sure the individual files that make up the packages to install all have the corrcet permissions also.

It also seems that you may, actually need to disable logon optimization http://www.eventid.net/display.asp?eventid=101&eventno=4011&source=Application Management&phase=1. I would systematically try to go through the suggestions in the event id 108 link above. go for what seem like the dumbest first and escalate to the more complex ones. then try disabling logon optimization.

let me know how it goes....
Answered 03/10/2010 by: squeakstar
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity