Hi All,

Here is the issue:
When i am trying to deploy Active Sync 4.5, I am getting an error 1327, Invalid Drive : H:\. But when i am installing the same package on my local VM, I am not getting any error.
I compared the log files in both the conditions, i couldn't figure out any particular thing. Here are the excerpts :
VM Logfile:-

Action start 16:37:32: CostFinalize.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding OutOfDiskSpace property. Its value is '0'.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding OutOfNoRbDiskSpace property. Its value is '0'.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding PrimaryVolumeSpaceAvailable property. Its value is '0'.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding PrimaryVolumeSpaceRequired property. Its value is '0'.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding PrimaryVolumeSpaceRemaining property. Its value is '0'.
MSI (s) (1C:70) [16:37:32:656]: Note: 1: 2205 2: 3: Patch
MSI (s) (1C:70) [16:37:32:656]: Note: 1: 2205 2: 3: Condition
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding TARGETDIR property. Its value is 'C:\'.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding GlobalAssemblyCache property. Its value is 'C:\'.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding INSTALLDIR.5F492FF1_28AE_4C56_A4D6_B40F4E565FD2 property. Its value is 'C:\'.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding INSTALLDIR.51671372_F8B5_4396_B5E6_A777BE5F4565 property. Its value is 'C:\'.
MSI (s) (1C:70) [16:37:32:656]: PROPERTY CHANGE: Adding My WHO Applications property. Its value is 'C:\Documents and Settings\All


Deployed machine Log file:-


Action start 9:15:17: CostFinalize.
MSI (s) (94:A8) [09:15:17:260]: PROPERTY CHANGE: Adding OutOfDiskSpace property. Its value is '0'.
MSI (s) (94:A8) [09:15:17:260]: PROPERTY CHANGE: Adding OutOfNoRbDiskSpace property. Its value is '0'.
MSI (s) (94:A8) [09:15:17:260]: PROPERTY CHANGE: Adding PrimaryVolumeSpaceAvailable property. Its value is '0'.
MSI (s) (94:A8) [09:15:17:260]: PROPERTY CHANGE: Adding PrimaryVolumeSpaceRequired property. Its value is '0'.
MSI (s) (94:A8) [09:15:17:260]: PROPERTY CHANGE: Adding PrimaryVolumeSpaceRemaining property. Its value is '0'.
MSI (s) (94:A8) [09:15:17:260]: Note: 1: 2205 2: 3: Patch
MSI (s) (94:A8) [09:15:17:260]: Note: 1: 2205 2: 3: Condition
MSI (s) (94:A8) [09:15:17:260]: PROPERTY CHANGE: Adding TARGETDIR property. Its value is 'C:\'.
MSI (s) (94:A8) [09:15:17:260]: PROPERTY CHANGE: Adding GlobalAssemblyCache property. Its value is 'C:\'.
MSI (s) (94:A8) [09:15:17:260]: PROPERTY CHANGE: Adding INSTALLDIR.5F492FF1_28AE_4C56_A4D6_B40F4E565FD2 property. Its value is 'C:\'.
MSI (s) (94:A8) [09:15:17:260]: Note: 1: 1327 2: H:\
MSI (c) (3C:48) [09:15:17:260]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg
MSI (s) (94:DC) [05:07:13:815]: Running as a service.
Error.Invalid Drive: H:\. Please select a valid drive.
Action ended 6:53:46: CostFinalize. Return value 3.


I have posted the code for reference. I checked all the registry table and the properties as well, but i could not find anything.
Please suggest.
Thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
It seems that the property 'INSTALLDIR.51671372_F8B5_4396_B5E6_A777BE5F4565' isn't being set/changed. Quite why it's defaulting to H:, I couldn't say but you need to figure why this property change is being skipped.
Answered 03/22/2010 by: VBScab
Red Belt

Please log in to comment
0
Thanks Ian,

I tried to delete that property coz it is being set by CA in the package. But, it didn't change anything.
However, in the Path Variables Section, i can see that a Pre-defined variable "WiseProjectPath" whose valuse refers to "H:\My Documents\Wise Setup\". But i am not able to modify the value. I am wondering if there is anything related with this.

Thanks.
Answered 03/22/2010 by: dnmech
Senior Purple Belt

Please log in to comment
0
Well, deleting the property wasn't what I suggested. What I suggested was that you find out why the property isn't being changed when you do a managed deployment. If, as you say, the property is being set by a CA, then the logical conclusion is that the CA is conditioned and that one or more of the conditions is False for a managed deployment. Thus, the property isn't set and the install fails.
Answered 03/23/2010 by: VBScab
Red Belt

Please log in to comment
0
Durgesh,

I've got a vague recollection of seeing something like this with ActiveSync before.

I think that the installer likes to check each drive on the system and if it can't read one for some reason, you get the error.
There are lots of people out there that have experienced the problem (according to Google) their drives have been SD card readers or the like, and once they put something to read in it the installation continues.

In your case it could be that the installation account doesn't have permissions to read whatever network drives your machine has mapped. - Worth checking.

Ultimately Ian's suggestion to prevent the CA running to cure the problem is probably the best way forward.

Hope this helps,

Dunnpy
Answered 03/23/2010 by: dunnpy
Red Belt

Please log in to comment
0
Again, my suggestion was not to prevent the CA running but to examine any conditions surrounding its execution to see why a managed deployment was preventing its execution.
Answered 03/23/2010 by: VBScab
Red Belt

Please log in to comment
0
Ian,

Sorry - didn't read you post correctly, was just trying to get my thoughts down and to stress that your way (as always) is the right way [:D]

Dunnpy
Answered 03/23/2010 by: dunnpy
Red Belt

Please log in to comment
0
No need to apologise, Paul. I was just clarifying things for the OP. And BTW - not reading posts properly is MY job!
Answered 03/23/2010 by: VBScab
Red Belt

Please log in to comment
0
I managed to change the property of that CA, but still i am getting the error. In log file i noticed one thing


MSI (c) (30:D4) [16:37:32:234]: SHELL32::SHGetFolderPath returned: H:\My Documents

Is there any way to change this?

Thanks
Answered 03/23/2010 by: dnmech
Senior Purple Belt

Please log in to comment
0
How are you deploying the package and what is your command line?

ALLUSERS is set to 1 in the vendor MSI, are you changing this value in a MST or on the command line?

Cheers,
Rob.
Answered 03/24/2010 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
Thnaks guys.

But, finally i was able to install the app wihtout the H:\ drive issue (guess i solved it) [:)].

I changed the proerty of PersonalFolder and MyPicturesFolder (by "Set property CA") at the time of OS checking itself . And this did the trick. Package installed fine.

Cheers!
Answered 03/25/2010 by: dnmech
Senior Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity