A PC has no programs listed under Discovered Software.  It shows zero.  This PCs inventory runs fine.  Its installed programs populate.  Installed Patches populates.  I can push scripts and run detects to the PC no problem.  But Discovered Software never populates.  We noticed that the inventoryData.Software file never gets generated in the directory.  It can't be a permission issue as all other files update when running an inventory or a detect.  Has any one else had this problem and any solutions?

We uninstalled the agent using the ALL switch and removed the KUID.  Removed the record out of the K1000 and reinstalled with no success.

Our over 400 other Dells have the same OS, WIN 7, AV is SEP and those run fine.  But this issue occurs enough to question how accurate my inventories are on the other PCs.

We have seen this before on other PCs with no solution form Dell.

0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


the Discovered Software uses a different process from the normal agent inventory and so even forcing the inventory multiple times you do not force the Discovered Software inventory process that normally runs every 24h only.
You can check a couple of things:
1-under Settings -> Appliance updates check the Software Catalog: is it updated? if not press the Check for Update button and check in the log that the K1000 is able to download it correctly
This Catalog is a database that the K1000 needs to compute the Discovered Software results.

2-under Settings -> Provisioning -> Communication settings check the Catalog inventory frequency: should be every day and I'd reccomend to live it like that but you can have it every 12 hours to speed up the initial collection process if you like.

kind regards,
 Marco - StockTrader
Answered 01/26/2016 by: StockTrader
Red Belt

Please log in to comment



Thanks for the suggestion but the issue isn't with the catalog not being updated as the other 400 PCs have the section properly populated under their inventory detail page.

When we go to this PC's inventory detail the discovered software is empty for this PC unlike the other 400 PCs that have this section filled in. 

When the agent is installed it should eventually create the inventoryData.Software file that should be located in the c:\programdata\dell\kace directory, but it isn't.  The other PCs all have the which contains the PCs discovered software .   That file is what populates the discovered software section for that PC's inventory detail.

There is something causing the routine not to run. 

Answered 01/26/2016 by: mjohnson007
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity