On a workstation where I had Wise Package Studio 4.61 Client installed, I tried to upgrade to 6.01 (after uninstalling 4.61).

However I got the following error:

Error 1904. Module \\servername\share$\Wise Package Studio\Manager\Repository.dll failed to register. HRESULT -2147312566. Contact your support personnel.

The installation stops at this point and then starts a Rollback. I didn't get the client installed.

I was finally able to install the WPS 6.01 client on my machine after following the recommendations of Wise Support which was as follows:

- Try manually registering the repository.dll on machine using regsrv32.exe.

- Remove any registry keys that are left behind under HKCU\Software\Wise Solutions.

- Remove any AlwaysInstallElevated registry keys on the machine

Then, reinstall the Wise Package Studio client on the machine.