Making a blog entry on this, since it's potentially useful and the formatting got messed up when I posted in reply to someone else's question.  Hope this helps!

__________________________________________________

 On KBOX:

1) Turn off "fail over to kbox" on the Replication share setting  

* Distribution - Replication - click on machine name - uncheck Failover To K1000

__________________________________________________________

* On target PC:

2) Add "debug=detail" (or "debug=true") to amp.conf in Dell\KACE directory  

* XP - C:\Documents and Settings\All Users\Dell\Kace  

* Win7 - C:\Programdata\Dell\Kace

3) Restart Dell KACE Agent service

4) Delete two files from the KACE program directory  

* XP - C:\Program Files\Dell\KACE  

* Win7 - C:\Program Files (x86)\Dell\KACE   

* mcescan.cab   

* mcescan.cab.checksum

__________________________________________________________

* On KBOX:

5) Run a detect only with any patch

__________________________________________________________

* On target PC:

6) Verify mcsescan files get copied down

7) Search pluginpatching.log for mcescan.cab  

* should find a line listing replication share machine like this:

[Wed Mar 28 14:10:59 2012] DownloadFile: Downloaded C:\Program Files (x86)\Dell\KACE\mcescan.cab from smb://domain;username:xxxxxxxxxx@servername/kpatch/repl2/patches/windows/mcescan.cab.f4b3680e53be3f25ba031e96a1954320 Download speed: 10358001 bytes/second

__________________________________________________________

John