We upgraded from Desktop Authority 9.0 to 9.2 and it broke our apps that utilize MSXML4. We called support to find out if they are doing anything with MSXML4 and we were told no and that our AV must have interfered. This is NOT correct. I unzipped the Desktop Authority msi package DAClientInstall.msi and TADA, inside was 4 DLL's having to do with MSXML4. The upgrade to DA 9.2 is breaking MSXML4. We are a hospital and this affected our ER and we had to declare a patient safety issue because we couldnt admit patients. All of this could have been avoided if Desktop Authority had a way to do the upgrade in a controlled manner and NOT resort to the shotgun approach. To me this demonstrates a small business mentality on their part. Upgrading the server to the new version and then it upgrading ALL the agents is completely unacceptable, especially in a large organization.

So to my question. Will Desktop Authority ever develop a way to upgrade their software in a controlled manner?

I will NOT upgrade again unless they develop a way to do it in a controlled manner. If they dont I will be looking for a replacement.
The ability to control the upgrade in a controlled fashion MUST be developed. This is unfair to the customer. I am going to explain all this to support and lets see if Dell does anything about it.

As a side note this is twice they broke our environment. The first was upgrading from 8.1 to 9.0. Their group policy deployment mechanism caused us to be in a loop of the GPO trying to install the old version 8 and when you logged in, it tried to install version 9.