check the component that is installing the DLL file had the following condition

MsiNetAssemblySupport > "2.0"

This means, the application needed a .Net runtime version greater than 2.0 to be installed prior to running this setup package.

OR

Resolution: Installing .NET Framework 4.0 will fix this issue.