/build/static/layout/Breadcrumb_cap_w.png

Systems Deployment Question


Windows 8 Scripted install Question

02/10/2015 1481 views
I am running a scripted install for Windows 8.1 pro. When it gets to the "Install OS" it is asking which partition to install on. I am trying to make this automated as possible, and would like to have this fixed. I do not have anything in the Setup Config for creating the partitions.

The following is what I have for my processes:

Create Single Partition:
select disk 0
clean
create partition primary
select partition 1
active
assign
exit

Format C: as NTFS:
format /q /y /s:enable /fs:ntfs c:

Install Vista/2008/7/8/2012/MBR:
bootsect.exe /NT60 c:
Answer Summary:
0 Comments   [ + ] Show comments

Comments


Answer Chosen by the Author

0

What I ended up doing was setting the partition sizes in the answer file. The following is the part I added under the "windowsPE"


    <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <DiskConfiguration>
        <Disk wcm:action="add">
          <CreatePartitions>
            <CreatePartition wcm:action="add">
              <Type>EFI</Type>
              <Size>200</Size>
              <Order>1</Order>
            </CreatePartition>
            <CreatePartition wcm:action="add">
              <Order>2</Order>
              <Size>128</Size>
              <Type>MSR</Type>
            </CreatePartition>
            <CreatePartition wcm:action="add">
              <Extend>true</Extend>
              <Order>3</Order>
              <Type>Primary</Type>
            </CreatePartition>
          </CreatePartitions>
          <WillWipeDisk>true</WillWipeDisk>
          <DiskID>0</DiskID>
        </Disk>
      </DiskConfiguration>
      <ImageInstall>
        <OSImage>
          <InstallFrom>
            <MetaData wcm:action="add">
              <Key>/IMAGE/NAME</Key>
              <Value>Windows 8.1 Pro</Value>
            </MetaData>
          </InstallFrom>
          <InstallTo>
            <PartitionID>3</PartitionID>
            <DiskID>0</DiskID>
          </InstallTo>
        </OSImage>
      </ImageInstall>
      <UserData>
        <AcceptEula>true</AcceptEula>
      </UserData>
    </component>
  </settings>

Answered 02/04/2016 by: SquirrelHermit
Yellow Belt

All Answers

0
This is what  I use... works great for me.

select volume 0 
remove all noerr 
select disk 0 
clean 
create partition primary size=350
assign letter="D" 
active 
create partition primary 
assign letter="C" 
exit

Answered 02/12/2015 by: nickbaldwin86
Yellow Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ