/build/static/layout/Breadcrumb_cap_w.png
06/08/2005 331019 views
Recently I tried to install Wise Package Studio and got the following message. "The system administrator has set policies to prevent this installation".

For my particular instance it was fixed by changing a value in the registry under

HKLM\Software\Policies\Microsoft\Windows\Installer

Name - DisableMSI Type - REG_DWORD 0 = enable

This was originally set to 1.

Hope this helps out someone else who comes across this error.

During my search I also found that there is a Windows Installer 2.0 Bug which sometimes throws up this message. If there is a trace of an application previously having been installed, and you are trying to re-install it, you may get the above error. You can fix this by going to the registry to:

HKEY_CLASSES_ROOT\Installer\Products\

Browse through and find your product. Delete the key relating to your product and this should allow the application to install. I haven't had the opportunity to check this out. But just in case someone is reading this and might need this resolution give it a go.

Y.
0 Comments   [ + ] Show comments

Comments


Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

All Answers

1
Hi 5uf:

HKEY_CLASSES_ROOT\Installer\Products\ normally fixes the error that u described and most of the times it worked with me. Did'nt know abt the first key thanks for sharing the knowledge though.
Answered 08/25/2005 by: wiseapp
Second Degree Green Belt

1
to y0u5uf:

thanks for the tip it helped me solve a problem with alcohol 120% not installing correctly
Answered 01/14/2009 by: patoruso
Yellow Belt

1
I am having the same problem and am unable to install ESEt Smart Security. How can I access: HKLM\Software\Policies\Microsoft\Windows\Installer
Thanks
Answered 08/20/2009 by: dfsahyoun
Yellow Belt

2
As the registry path suggests these settings are managed by AD group policy. Changing them is OK for testing purposes but any permanent changes required to this (or any other policy setting) should be considered and implemented by your group policy administrator.

A value of 1 means that Windows Installer is only enabled for managed deployments (read AD or SMS)

http://msdn.microsoft.com/en-us/library/aa368304(VS.85).aspx
http://msdn.microsoft.com/en-us/library/aa369784(VS.85).aspx

It's normally used to secure desktops and in conjunction with the AlwaysInstallElevated setting/s

http://msdn.microsoft.com/en-us/library/aa367561(VS.85).aspx
http://msdn.microsoft.com/en-us/library/aa372395(VS.85).aspx

Hope this helps,
Rob.
Answered 08/20/2009 by: MSIPackager
Third Degree Black Belt

1
This is a personal computer and it is not allowing me to install the anti virus smart security from ESET software. Please walk me through... thanks
Answered 08/20/2009 by: dfsahyoun
Yellow Belt

4
Yes Thankyou

HKLM\Software\Policies\Microsoft\Windows\Installer

DisableMSI Type = 0 ( enable MSI )

This was originally set to 1 (disable MSI )

Also try this key ...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\{A541BD3D-1A70-4D7B-BC99-CF1ADFC0DE9F}Machine\Software\Policies\Microsoft\Windows\Safer

Change this value to 1 - to disable the Administrator only install a.k.a
anyone can do it.

If all fails .... The system Administrator has set policies
to prevent this installation,,,,, ensure you are logged on as Administrator
or any Administrative User privileges or Right click setup.exe and Run As Administrator
Answered 11/22/2011 by: levene
Yellow Belt

  • where do I go to the above to change the disable MS! type from 0 to 1?
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
0

I have the same problem, could you please tell me how I can access this to change, I am a beginner :(

Answered 06/04/2013 by: ateam
White Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share