/build/static/layout/Breadcrumb_cap_w.png
02/26/2019 791 views

Hello,

We have v5.0.22 of the Kace SDA and the Driver Feed can't differentiate between different Surface versions to apply correct drivers in the imaging process. Do we need to upgrade the SDA to a more recent version to correct this?

Using the Driver Feed Discovery Tool I only see "Surface Pro" when I run it on different versions.

I ask because we seem to be having several devices BSOD, and have only resolved one by wiping out the drivers and installing the correct ones.

Or would it just be best to use the Microsoft Surface Deployment Accelerator?

What has your experience been with K2000 and deploying Surfaces?

0 Comments   [ + ] Show comments

Comments


All Answers

0

I'm pretty sure I have seen that tool working fine with Surface devices.

Are you running it after copying the whole Feed Tools Folder, to the surface's Windows Desktop? (do not run it from the Samba Share Folder, do not copy the VBS file alone).

Make sure the OS is installed, running it from the KBE will not print the whole Path.

Maybe upgrade to 5.1 (supported version) and see if that helps.

https://support.quest.com/kace-systems-deployment-appliance/lifecycle


Also if you open CMD from Windows on that Surface, and do a WMI query, will it print the model??

C:\Users\msuski>wmic computersystem get model, manufacturer,systemtype

The Driver Feed builder uses WMI to build the path where is saved. If you run that in any other brand, like DELL or Lenovo, or HP, the Model should be the device model itself.



Answered 02/26/2019 by: Channeler
Red Belt