/bundles/itninjaweb/img/Breadcrumb_cap_w.png
i have spss package and it work fine but went a user save a file and try to click on any spss *.sav file it doesn't open spss it state that spss is not install but if you open spss them go to open and them pick the file is works fine. i check the assocation and it fine doesn't one have any recommendation, i check to see if any files or missing but they are all there.
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
Can you be more specific about the error?

You say your association is "fine", but it obviously isn't.

These are the registry keys that should be of interest (for per-machine install):

[HKEY_CLASSES_ROOT\.sav]
@="My.ProgID"

[HKEY_CLASSES_ROOT\My.ProgID\shell\Open\command]
@="Non-advertised clear text command line"
"command"=Illegible advertising garbage

You can aslo use the following commands from a command prompt for trouble-shooting:

Assoc .sav (returns associated ProgID)

Ftype My.ProgId (returns non-advertised commandline for given ProgID)
Answered 05/21/2005 by: WiseUser
Fourth Degree Brown Belt

Please log in to comment
0
i did that dos thing with the assoc.sav and it didn't work the msg is you don't have a valid product install
also i did the registry thing also no help
Answered 05/23/2005 by: linstead
Blue Belt

Please log in to comment
0
What were the contents of the registry keys I asked about?

[HKEY_CLASSES_ROOT\.sav]
@="??????"

[HKEY_CLASSES_ROOT\My.ProgID\shell\Open\command]
"command"=??????

What happens if you delete some registry keys as follows:

[-HKEY_CLASSES_ROOT\.sav]

[-HKEY_CLASSES_ROOT\My.ProgID]

And then repair your application from the control panel?

Btw, do you have the following key in your registry?

[HKEY_CURRENT_USER\Software\Classes\.sav]
Answered 05/23/2005 by: WiseUser
Fourth Degree Brown Belt

Please log in to comment
0
classes root\sav has
spss.datadoc no valve
shellnew no vale

i search the entire registry and no entry for [HKEY_CLASSES_ROOT\My.ProgID\shell\Open\command]
"command"=??????
i also do have a current user classes\.sav key
if i delete the .sav key from classes root i get the same error

which is
the action is only vaild for products that are currently installed
thanks
Answered 05/23/2005 by: linstead
Blue Belt

Please log in to comment
0
You don't need to search the registry since I'm giving you the exact path:

[HKEY_CLASSES_ROOT\spss.datadoc\shell\Open\command]
"command"=?

Is the key there?

Try deleting the user file association:

[-HKEY_CURRENT_USER\Software\Classes\.sav]

What happens then?
Answered 05/23/2005 by: WiseUser
Fourth Degree Brown Belt

Please log in to comment
0
yes that key is there

i don't have the [-HKEY_CURRENT_USER\Software\Classes\.sav]
Answered 05/23/2005 by: linstead
Blue Belt

Please log in to comment
0
sorry about the last post

[HKEY_CLASSES_ROOT\spss.datadoc\shell\Open\command]
"command"=?
is there
the [-HKEY_CURRENT_USER\Software\Classes\.sav] i don't have
Answered 05/23/2005 by: linstead
Blue Belt

Please log in to comment
0
i also do have a current user classes\.sav key

Didn't you type the above sentence in an earlier post?

Try uninstalling your package, then reinstalling it using the following command line:

Msiexec /i whateveryourmsiiscalled.msi ALLUSERS=1 /qb

If it still doesn't work, create a new local user and try running the application as that user.

If it still doesn't work, try the same thing on another (clean) PC.
Answered 05/23/2005 by: WiseUser
Fourth Degree Brown Belt

Please log in to comment
0
i think i see that problem the open command have a /dde on it so i remove it and it works fine
Answered 05/23/2005 by: linstead
Blue Belt

Please log in to comment
0
linstead,

Just curious - what version of SPSS are you working with, and are you using it's native .msi?


Craig --<>.
Answered 05/24/2005 by: craig16229
Third Degree Brown Belt

Please log in to comment
0
craig version 12 and no i am not using there native msi because i was trying to do a transform but i can't soppress one of the dialog box but if you know about spss please let me know you can email or i have aim or yahoo just let me know your user name and we can talk
Answered 05/24/2005 by: linstead
Blue Belt

Please log in to comment