/bundles/itninjaweb/img/Breadcrumb_cap_w.png
OK. So I have a labels D-Desktops (All subtype = Desktop) and D-Laptop (All subtype = Laptop).

If I go under inventory and devices and use "smart label" option to display lets say everything with subtype "Laptop". I get a result of 127. But if I go to home->label management -> label, and home->label management -> smart labels and select D-Laptop, I only see 113. I did forced Inventory on entire inventory, and I made labels yesterday but still it does not seem to be fully updates. Anyone have any ideas what is going on and how to resolve it? 
2 Comments   [ + ] Show comments

Comments

  • From what I remember (I could be wrong though), smart labels are applied when a device performs/submits its inventory. My guess is that you had 14 devices, that had not performed an inventory since you created the smartlabel.

    If you sort the device list by "Last Inventory", do you have any devices that are far behind ?
    • Sorry, this is part of the problem. Is there a way to adjust the auto inventory time? Can I set a schedule to have a group force inventory like I can patches?
      • You can configure the agent inventory interval from the Communication Settings page ("/adminui/settings_client.php"). Do note though, that it can have a significant impact on the performance of the kbox, so you should monitor the task throughput following any changes.

        For setting a stricter schedule for a certain group of devices based on a label, it might be possible through scripts. I'm not certain what the most optimal way of performing this would be, but you could perhaps duplicate the original inventory script ("/adminui/kbot.php?ID=4"), adding the intended label to the duplicated script instead of "All Devices" and changing the schedule to the interval you want for those specific devices.

        Also note that if a device is not connected (Status) to Kace, an inventory cant be performed for that device and the smartlabel can therefore not be applied.
  • Thanks for the help. I think I got that figured out now.
Please log in to comment

There are no answers at this time


Answers

Share