/build/static/layout/Breadcrumb_cap_w.png

RunOnce bug in Windows 10??

Just wondering if anyone else has tried this...

With Windows 7 and 8, the HKLM RunOnce and RunOnceEx registry keys run prior to the desktop loading, as designed. The desktop won't appear until they have completed.  With Windows 10 the keys kick off but the desktop appears after a few moments regardless of whether the keys are still running.

Any thoughts about how to workaround this?

0 Comments   [ + ] Show comments

Answers (2)

Posted by: EdT 5 years ago
Red Belt
0
I think you will need to configure your runonce entries to run synchronously. The following technet article gives some pointers:

https://technet.microsoft.com/en-us/library/dd346765.aspx


Comments:
  • Thanks but I'm not sure if that applies here. I don't have any problem launching tasks that run in order, the specific issue is that the desktop isn't supposed to load until the RunOnce keys have finished. - nheyne 5 years ago
    • >the specific issue is that the desktop isn't supposed to load until the RunOnce keys have finished.
      ...except that, as explained, this behaviour has changed in W10. This is to give the illusion that Windows is loading faster. - anonymous_9363 5 years ago
      • And where is this explained?? - nheyne 5 years ago
Posted by: dedenker 5 years ago
3rd Degree Black Belt
0
Because of my own interest I start googling around, and first found this article, but only applies to Windows 7 & 8.
Then I found some tools to delay start up of applications here, perhaps it is a good alternative...

For Windows 10 wants look at fast as possible...that you still have to wait for other apps to load doesn't matter.
So long you can watch the nice photoshop picture on the background...

What you could investigate is your own recurring 3th party update, for that is the only thing that can slow down the desktop appearance. (Previous version this was possible).
Please share if you do find a solution!

Comments:
  • After many hours of doing my own research, I stumbled across the solution that worked for me.
    The first answer was sort of correct. Prior to 10, Windows would run the RnOnceEx commands synchronously. This has now been changed to asynchronously which means the Explorer shell can run when it wants to, instead of after the RunOnceEx commands/keys have completed, as confirmed in this article, which is also where the answer lies -
    http://blogs.technet.com/b/mniehaus/archive/2015/08/24/windows-10-mdt-2013-update-1-and-hideshell.aspx
    Therefore, you need to add the following reg key - reg add HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer /v AsyncRunOnce /t REG_DWORD /d 0 /f

    While the article states to add a line to your Unattend.xml file, I like to do this old school. My Setupcomplete.cmd file calls up my reg tweaks in a separate file using the following -
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer]
    "AsyncRunOnce"=dword:00000000
    I also run the disable animation tweak as that really bugs me too!!! - Atomicmaniac 5 years ago
 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ