I use Installshield 11; I have a vendor msi that when run does not register an ocx file.
Problem being is that in direct edit mode I am unable to tell the file to self-register. (Always crashes installshield, but thats another story).

So I captured the registry settings that register the file and put that into a new component in the msi. And everything is good.


I have several mst's built that install the program in specific ways. When I install the program using one of the MST's the registry settings that I put into the MSI for the register of the OCX file do not install.

All the MST's have are a few registry settings in HKLM so I dont see how that should effect it all.

So I took the registry settings and put them into the MST file as well and it still wont install!

Its driving me nuts.

Anyone have a suggestion?
0 Comments   [ - ] Hide Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity


Hi emuringer,
I dont think modifying the vendor MSI is a good idea. Have you tried using the regsvr32 to register ur .ocx file within ur package?.
In case u havent, script a CA to register and unregister the .ocx file during install and uninstall respectively within ur MST.
Syntax (install): regsvr32 /s <Full path of .ocx file>
Syntax (uninstall): regsvr32 /u /s <Full path of .ocx file>

Let me know if this works for u. By the way, are using calling all those MST's during install?? Verify the command line options ur using for installing the app.

Good luck,
Answered 09/21/2005 by: sridtech
Senior Yellow Belt

Please log in to comment
Thanks for the reply sridtech,

command line is :
msiexec /i Blah.msi TRANSFORMS=blah1.mst

which mst the PC would receive would be determined by its job function.

I will try the CA. I figured I would have to do this but our department really frowns on creating our own CA in our packages. Something with deploying via SMS or something.

What really bothers me is that I really should not have to do this.

Answered 09/21/2005 by: emuringer
Senior Yellow Belt

Please log in to comment
I got this fixed now.

Had to re-insert the OCX file making sure to extract the COM information.
Answered 09/21/2005 by: emuringer
Senior Yellow Belt

Please log in to comment