/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Curious if anyone out there has figured out how to prevent HipChat from launching following installation using Atlassian's MSI? I tried using LAUNCHHIPONEXIT=0 or LAUNCHHIPONEXIT=-1 when executing the MSI, but neither one of those worked. By default, LAUNCHHIPONEXIT is set to 1. Ultimately, I used a transform file to change the condition that causes HipChat to open because its dependent on another variable that I can't modify.

Before Transform: 
Action: LaunchApplication
Condition: LAUNCHHIPONEXIT AND UILevel <> 5

After Transform:
Action: LaunchApplication
Condition: LAUNCHHIPONEXIT <> 1
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Answer this question or Comment on this question for clarity

Answers

1
When a property is used "bare" - i.e. with no explicit value - in a condition, the value assigned to it doesn't matter. You could have tried 'LAUNCHHIPONEXIT=AreYouSerious' and witnessed the same effect. What you need is for that property to not be there at all.

Thus your options are to edit the MSI directly and remove the property - not recommended, as you know - or use a transform.

My question would be, what's the big deal about using a transform, that you'd want to not use one?
Answered 04/25/2018 by: VBScab
Red Belt

  • Thank you for clarifying! The transform works, so I really shouldn't discount it, but I wanted to make sure that I wasn't missing something where I could make it work without the transform file.
    • The correct property setting is LAUNCHHIPONEXIT="" to set it to no value so that the condition evaluates False. Unfortunately, even LAUNCHHIPONEXIT=0 is setting it to a value that will make the condition evaluate to True.
      • Oh cool! This is what I was looking for. Thank you!
Please log in to comment