/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Just wondering how I change permissions on a INI file using AdminStudio 6? As it's not treated as a normal file there doesn't appear to be an option for it. Will I need to create a custom action?

Any help would be appreciated.

Cheers,
Johan
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
dunno about admin studio specifically, but with any MSI you can call a custom action to cacls to set the permission on the file....
Answered 11/21/2005 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
I dunno about admin studio, but I know Wise sometimes has problems with INI files. What I usually do is delete the INI file from the INI section in the setup editor. Add the INI file as a regular files. Make sure to remove the keypath to avoid self-healing. Then you can manually set permissions to the file.
Answered 11/21/2005 by: urban_diver
Orange Senior Belt

Please log in to comment
0
I did think about importing it directly as a file, but I was kinda hoping I wouldn't have to. I know it's alot more fiddling, but I think going for a custom action might be a better way for what I need to do. I prefer to run Secedit as apposed to Cacls though.

Cheers,
Johan
Answered 11/21/2005 by: JohanE
Senior Yellow Belt

Please log in to comment
0
Did you try setting permissions to component in which the ini file is present?
Answered 11/29/2005 by: Novice_123
Orange Belt

Please log in to comment
0
May be you can also try in the table level permission setting also.

HTH
Answered 11/30/2005 by: slb
Purple Belt

Please log in to comment