Kace SMA Offboard Backup failing to write incremental files

We've had Kace SMA (K1000) Offboard backups enabled and working since they were first announced.  No issues until 4/5/2023.  At that time, started receiving a daily "Offboard Backup Failed" notification upon login.  This is a VM (Kace version 13.0.383) on Hyper-V, backing up to a file share on a 2019 Windows Server.  Testing the backup from the Kace settings works fine.  Kace copies over the Base Backup weekly, and the Base backup shows a "Date Modified" daily.  The incremental backup, on the other hand, doesn't ever copy over anymore.  The Backuplog looks to show that the Base didn't transfer, but the file is plainly written on the File Server.  Error logs:

2023-04-18.03:05:26-0500|INFO |KOffboardBackupLogger.trait.php:42:logMessage| ***** Offboard backup process started. *****|

2023-04-18.03:05:26-0500|INFO |KOffboardBackupLogger.trait.php:42:logMessage| Copying /kbackup/20230415_k1_base_13.0.383.tgz to Samba share|

[2023-04-18 03:06:39 -0500] [offboard_backup] Samba Failed: NT_STATUS_IO_TIMEOUT closing remote file \20230415_k1_base_13.0.383.tgz

Less than a minute from "Offboard started" message to "Samba Failed"...  From what I understand, the NT_STATUS_IO_TIMEOUT error tends to lead towards an authentication issue, but I've verified authentication several times with several identities at this point.  I know that Samba has file limitations that we are WAY past (8GB Base, 2GB Incremental), but we've had these size backups for several years, basically since we started using Kace SMA for Win10 Feature Updates via Managed Install before that feature was built in.

Anyone got any suggestions here?  I can FTP the files off manually, so we're getting our backups, but DO miss the Offboard process working correctly.  

0 Comments   [ + ] Show comments

Answers (2)

Posted by: AshleeAA 3 weeks ago
White Belt

Having the same issue in our environment, though there was a change from 2012R2 to 2019 for the offboarding server. Other appliances are backing up using SMB using the same credentials without incident, and the base file comes in the same as yours but we never get incremental backups. 

  • Ended up getting a response from Kace support that this issue isn't exactly widespread, but it's affected multiple Users and they have an investigation going on to figure it out. The exact same issue, base file writes, incrementals do not. - aintITcool 3 weeks ago
Posted by: agibbons 6 days ago
Purple Belt

Cross posted on Reddit as well. Did you ever hear more? I have the same issue. I mentioned to support that I read other customers have the same problem, and that perhaps Quest is already investigating this?

  • Sorry to be the bearer of bad news, but no-go on the fix. Kace Support said it's due to a Windows Update, they're not exactly sure which one, but it affected Kace versions 11-13. While they're still investigating, they're also recommending that everyone ditch SMB and move to SFTP...which in my mind means they're not investigating it THAT much. - aintITcool 6 days ago
    • Thanks for the heads up. I guess all things considered, it half breaking, and only the *full* back up landing offboard is a not too bad way to break. The suggestion to just not use Samba is hopefully stopgap only - agibbons 6 days ago
    • Update: pointing K1000 offboard backups at a newly created Samba share (same credentials, same file server, just a newly created directory) seemed to resolve the issue for us. - agibbons 4 days ago
      • Think you and I are having the same conversation on Reddit currently, but for whomever stumbles across this post years from now...this worked for me as well, at least on a manual run. I've yet to see it work on a schedule, but no reason to think it won't. - aintITcool 4 days ago
      • Yeah, put this both here and Reddit :) It worked for a manual backup yesterday, then ran properly overnight during the scheduled backup. Here's hoping it'll work for you, and also that it'll stick - agibbons 4 days ago
      • Thanks for this! Renaming the share also works. - AshleeAA 3 days ago

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login


This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ