/build/static/layout/Breadcrumb_cap_w.png

KACE agent 10.1.43. upgrade

All of the devices in our environment are running agent 10.1.43. I have upgraded the SMA 11.1.264. When I try to k1000_agents_11.1.103 I get the following message.

Proceeding with the upgrade will immediately and permanently disconnect and deactivate all legacy (pre-version 11.0) agent-managed devices. Only 11.0 and later agents will be allowed to connect after this change.

How do I get my machine up to the latest version of the agent?


0 Comments   [ + ] Show comments

Answers (2)

Posted by: KevinG 1 month ago
Red Belt
0

In the future, prior to upgrading, you may want to review the System Requirements listed in the product release notes.

The minimum version required for upgrading the KACE Agent is 10.2. We recommend running the latest agent
version with KACE Systems Management Appliance 11.1.

Newer versions of the Agent may become incompatible when the communications change between the SMA and Agent.

Also, security updates can be a factor in compatibility.
You may be able to use something like psexec to run a script on the device to uninstall the previous version and install the new version. After you have resolved this issue. I highly recommend that you continue upgrading all the way to 12.1.169 of the SMA and update the Agents to 12.1.x.

Posted by: Hobbsy 1 month ago
Red Belt
0

Download the agent installer from the SMA and then run it to uninstall and install the latest version

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ