/build/static/layout/Breadcrumb_cap_w.png

Scripting Question


K1000 Not Inventorying on machines [AGENT 7]

02/19/2017 3505 views
Hi Men,

We are having issues with machines not checking into K1000 after the update to Agent 7
Have read around on a few posts and have tried the troubleshooting but still nothing seems to remedy the situation.
If all our machines weren't checking in then that would a little easier to troubleshoot but only about HALF are checking in and the rest are not
Have tried the following;

- netstat -nao Checked that client and appliance are connecting to ports 443 / 52230
- Telneted into 192.x.x.x:443 from client PC to Appliance all working fine.
- Checked logs in ProgramData/Kace/User and all point to no connection issues with appliance 
- Reinstalled KACE Agent on Machines as a test and still no difference
- Checked the AMP.CONF to see if it had been wiped as previously stated in other posts. All data is still there
- Ran a offline check in script on machines to get them to check in no luck.

On reflection, it seems that K1000 are not applying inventory settings and machines are checking in on their own accord.

I have not come across this behavior before, any help will be great

Thanks :D
1 Comment   [ + ] Show comment

Comments

  • Do you have a custom logo ? It may be somthing like this question http://www.itninja.com/question/agents-checking-in-not-inventorying
    • Hey Gwir,
      Thanks for the link, we did actually have a custom logo and when we tried to remove and had some issues since.

      We still seem to have about 200 machines that aren't checking in but we've disabled Replication shares and allowed port 80 and disabled SSL
      We're still looking into this and will post finding once known!

All Answers

3
hello !

I had the same problem. Here is the solution.

140/420 PC's has the problem for me

with cmd go to this folder: 

- cd "c:\Program Files\Dell\KACE"
- amptool.exe uninstall all-kuid
- reinstall Kace Agent Manually \\KACE_HOST\client\agent_provisioning\windows_platform
- after reinstallation go with cmd to Kace folder cd "c:\Program Files\Dell\KACE"
- run this command "runkbot 4 0"

EDIT - Thanks El_Duderino: 
-These command must be run from an Administrator command prompt to work correctly.
-If you are running a 64bit OS, the correct path is "c:\Program Files (x86)\Dell\KACE"

go to k1000 and check your computer and normally all is ok

next you can create a batch and apply by GPO

Thank to Quest Support for the solution :)
Answered 03/14/2017 by: samijuke
White Belt

  • You have a typo: "apmtool.exe uninstall all-kuid"
    should be: "amptools.exe uninstall all-kurd" (corrected)
    • Sorry !, I correct that, thanks
      • Thanks! Saved me a lot of time. Just a couple of addition though;

        -These command must be run from an Administrator command prompt to work correctly.
        -If you are running a 64bit OS, the correct path is "c:\Program Files (x86)\Dell\KACE"
        -The command should be "amptools.exe uninstall all-kuid"

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

View more:

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ