/build/static/layout/Breadcrumb_cap_w.png

KACE Product Support Question


K1000 migration - restore gives no feedback; ftp says existing file doesn't exist

03/24/2017 1434 views
I have a physical ver 6.4 K1000 that has a few years worth of data. The hardware is out of warranty now, and we're moving to a virtual appliance.

I have set up the virtual K1000, with ver. 7.

As per the documentation I've found, the old K1000 also needs to be ver. 7 (exact same vers on both machines).

So I have upgraded the old K1 to vers 7, no problem.

Then I did a backup of the old K1, and downloaded the two backup files to a local drive, and powered off the old K1

Then from the new K1, I'm trying to upload the two backup files, and although the Upload/Browse buttons see and accept the files, when I click on "Upload files", the status line at the bottom just sits forever saying "Sending request to K1000.domain". After waiting several hours, and trying over several times, I decide that maybe the ftp route would work (as I've read in a 6.4 instruction on the web - can't find the same instructions for ver. 7).

When I ftp into the new k1000 (took forever to find what username I was supposed to use), I can see the backup files. The instructions I found said to delete the current day's files, and replace them with the backup files from the old k1000. I can see the files plain as day with an "ls -alh", but when I try to delete one of the files, it complains that the file does not exist. (This is even when I use tab-completion to enter the filename on my delete command, so I'm not introducing any typos in the name, and the tab-completion sees the file.) I've verified that ftp is set to write-enabled.

So I thought I might try ssh'ing in to delete the files. ssh is enabled, but the only username I can find that semi-works is "root", but then it asks for a verification code after I enter the password, and I have no idea about any verification code.

Can anyone help me out?

Thanks!

--
Kent



Answer Summary:
7 Comments   [ + ] Show comments

Comments

  • Update 1:
    I was using Firefox 52.0 64bit. I switched over to Chromium 56.0.2924.76 64bit, and that made a difference. Now I'm able to upload the backup files. Why Firefox is disagreeable is beyond me.
  • Update 2:
    As I mentioned above, I've been using tab-completion to enter the name of the file to delete, but what I didn't notice is that it was tab-completing a filename not even in this directory.

    I've never seen that before. Since when does tab-completion go find files in some other directory than the one you're in?
  • Update 3:
    Well, the update of the backup files completed, and I was able to click on Restore from Backup. It cooked a while, then rebooted, and ...
    No change whatsoever.

    I'll go try the ftp route again, now that I've discovered it's doing janky things with the path on the command line.
  • Well, I say there's absolutely no change whatsoever. The ftp option somehow got turned off....
  • I turned ftp (enabling write) back on, and ftp'd in, and am still seeing that janky command-line behavior, wherein the file exists to my eye, but doesn't exist to the ls, del, or tab-completion commands. I've created a new question for this issue of ftp being janky.

    But, how do I delete these files if the del command won't see them?
  • So since I can't delete the files via ftp, I will try uploading the backup files again, and restore them again.

    This time, I'm back to the browser just sitting there doing nothing after I click on "Upload Files". (Well, not nothing; it does say, "Uploading (0%)..." perpetually.)

    I'm really beginning to think that the KACE K1000 is severely b0rken in several respects.
  • Did you find your restore went as expected? My restore isn't working. The backup log says "backup files are not compatible. We're in a similar boat... migrating away from a physical appliance to a virtual one. The versions of the SMA are a dead match (7.1.150). There is no detail on why the files are not compatible.

Answer Chosen by the Author

0
ftp was set to writable.

I changed ftp clients, which solved my ftp command-line weirdness.

I did a factory-reset of the K1000 which solved the "permission denied" errors (not mentioned in this post, but discovered after I changed ftp clients and got beyond the command-line weirdness).

ssh still does not work, but samba mounting \\kbox1000\clientdrop does, as does ftp uploading, so I'm good now. (I would like to get ssh working, just so I know in the future that it's a usable tool, but that's low priority right now.)

/Kent

Answered 03/27/2017 by: kentwest
Brown Belt

  • After it's all said and done now, I notice one other detail I thought it might be good to document.

    The original K1000 backup files are owned by user 80, group 0, but the file I uploaded via ftp is owned by user 1004, group 9, and the file I uploaded via clientdrop is owned by user 10001, group 14. Makes me wonder if permissions on the share or on the parent directory were set incorrectly before my factory reset, and if so, how they got set that way.

All Answers

0
Under Settings -> Control Panel - Security Settings  check that "Make FTP writable" is selected below "Enable backup via FTP"
Answered 03/25/2017 by: KevinG
4th Degree Black Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ