/build/static/layout/Breadcrumb_cap_w.png

JRE 1.6.0_05 Automatic Update - deployment.properties problems

I have done all the mentioned regvalues changes but one thing is still bothering me.

What about the deployment.properties file in "c:\Documents and Settings\[user]\Application Data\Sun\Java\Deployment" , when i start the javaconsole this file is created (ie not during the installation) and the standard setup is set to "download JRE automatically". I read somewhere that this is an error in the console but I'm not sure... all of the mentioned regvalues are changed, this is the only thing that is bothering me... any suggestions?

kindly Piotr

0 Comments   [ + ] Show comments

Answers (16)

Posted by: spartacus 13 years ago
Black Belt
2
Have you considered using a system-wide deployment.properties file ?

The following article discusses this in more detail :

http://java.sun.com/j2se/1.5.0/docs/guide/deployment/deployment-guide/properties.html

For example, you could try creating a [font="courier new"]deployment.config file in the folder C:\Windows\Sun\Java\Deployment, which would contain the following line :

[font="courier new"]deployment.system.config=file\:C\:/WINDOWS/Sun/Java/Deployment/deployment.properties
[font="courier new"]
and then create a new deployment.properties in the folder C:\Windows\Sun\Java\Deployment which would contain the following lines

[font="courier new"]deployment.javaws.autodownload=NEVER
[font="courier new"]deployment.javaws.autodownload.locked=
[font="courier new"]

Regards,

Spartacus
Posted by: spartacus 13 years ago
Black Belt
2
Made a couple of mistakes in my earlier post which I've now edited and also have had the chance to test them myself.

In the Java Control Panel advanced tab, the settings from the system-wide deployment.properties do appear to have been actioned. Also, using the [font="courier new"]deployment.javaws.autodownload.locked[font="times new roman"] entry seems to have usefully grayed out the option to alter the setting.

Regards,

Spartacus
Posted by: MicrosoftBob 13 years ago
Blue Belt
0
Here's a possibility:

-Customize deployment.properties the way you want it.
-Then copy it to all existing profiles including "Default User" on the target machines. This will ensure existing and new profiles will get your version of the file.
Posted by: MSIPackager 13 years ago
3rd Degree Black Belt
0
-Customize deployment.properties the way you want it.
-Then copy it to all existing profiles including "Default User" on the target machines. This will ensure existing and new profiles will get your version of the file.


The problem with this method is that the file contains the username in the javaplugin.cache.directory= path. So, unless you want to use a common path (e.g. javaplugin.cache.directory=C\:\\Windows\\Temp) you'd be better of using activesetup to run a wise or vb script copy a template file then update the file to enter the username.

Cheers,
Rob.
Posted by: piotr.kuczkowski 13 years ago
Orange Belt
0
Well..I already tried this, I copied the SUN folder with the content to the user directory (and all other directories), but the first time the console is activated it overwrites the deployment.properties file..... Tried to monitor the registry, but there seems to bee no regvalue that controls wheter the conosle has been started before or not....

If I have made the "normal" regvalue changes to avoid update, as is described in the packade KB, will it still update or not? I can't be the only one that hav thought about this problem right?

kindly,
piotr
Posted by: MSIPackager 13 years ago
3rd Degree Black Belt
0
In my experience, the deployment.properties file is only created if you change any of the default values. Just running the control panel applet (I'm guessing this is what you mean by the console?) does not create the file.

Likewise, if the file already exists (copied by activesetup or whatever) it doesn't get overwritten - the applet displays the settings based on the values in our customised deployment.properties file...

We are running J2RE 1.4.2_08 - perhaps later versions behave differentyy but I'd be surprised.

Cheers,
Rob.
Posted by: piotr.kuczkowski 13 years ago
Orange Belt
0
thanks Rob, but the 1.6_05 is acting differently from your version. Accessing the "control panel" automatically generates the folders and the deployment.property file... all changes in the "control panel" updated the file too...

But I think I'm on my way to solve it....will get back when I know more...

kindly,
Piotr
Posted by: MSIPackager 13 years ago
3rd Degree Black Belt
0
Nice one, thanks for the info :-)
Posted by: piotr.kuczkowski 13 years ago
Orange Belt
0
spartacus, you are GOD..... It worked, directly althought I must say I doubted it, the turorial was for 1.5.X and not for 1.6, but it worked.... The settingt all are taken from the global deployment.properties file, sweet...
One could wonder what the registry key values are for....

thank you for the help, and thanks guys!

kindly,
Piotr
Posted by: Geronimo 12 years ago
Yellow Belt
0
It doesn't seem to work for us.
We created the 2 files and placed them in the C:\Windows\Sun\Java\Deployment directory.
After install in Control Panel it is still accessible and the automatic update is still selected.

We use version 1.6.0_06

What are we doing wrong?

Regards,
Edwin
Posted by: spartacus 12 years ago
Black Belt
0
If you click on the "Advanced" tab in the Java Control Panel and expand the "JRE Auto Download" branch of the tree, what is the setting showing there ?

Regards,

Spartacus
Posted by: jimmyx 12 years ago
Purple Belt
0
Hi,
I'm looking to deploy Java 6 Update 7 and have followed Spartacus instructions
re: Auto-Download. The settings are being picked up as expected with the JRE Auto-Download options being greyed out in the advanced tab. However I would also like to disable the update tab so users cannot attempt to download updates from there.

Is it possible to disable that tab? Have I missed something simple?

regards
Jimmy
Posted by: jimmyx 12 years ago
Purple Belt
0
Woops please ignore above post looks like the update tab is only available for administrators!

Jimmy
Posted by: A R N O 12 years ago
Yellow Belt
0
ORIGINAL: Geronimo

It doesn't seem to work for us.
We created the 2 files and placed them in the C:\Windows\Sun\Java\Deployment directory.
After install in Control Panel it is still accessible and the automatic update is still selected.

We use version 1.6.0_06

What are we doing wrong?

Regards,
Edwin



In my case these 2 files must be placed in "C:\Program Files\Java\jre6\lib"

You can read that in this article:
http://java.sun.com/j2se/1.5.0/docs/guide/deployment/deployment-guide/properties.html

Everything works fine now [;)]
Posted by: aogilmor 12 years ago
9th Degree Black Belt
0
ORIGINAL: spartacus

Have you considered using a system-wide deployment.properties file ?

The following article discusses this in more detail :

http://java.sun.com/j2se/1.5.0/docs/guide/deployment/deployment-guide/properties.html

For example, you could try creating a [font="courier new"]deployment.config file in the folder C:\Windows\Sun\Java\Deployment, which would contain the following line :

[font="courier new"]deployment.system.config=file\:C\:/WINDOWS/Sun/Java/Deployment/deployment.properties
[font="courier new"]
and then create a new deployment.properties in the folder C:\Windows\Sun\Java\Deployment which would contain the following lines

[font="courier new"]deployment.javaws.autodownload=NEVER
[font="courier new"]deployment.javaws.autodownload.locked=



Well hot damn, since we're all replying to old threads LOL....thanks so much for this. I am going to try that on my NEXT java install (last just went out). Goes to show maybe I should review appdeploy, i thought i knew java installs. This time I use the usual trick of setting/deleting the reg keys as the last step of the install, and to be a real smarass I put a CA in that deleted the update and schedule executable - just try to update now, suckers! But your solution is much more elegant. 2 ratings points. :-)
Posted by: Matthew Glew 11 years ago
Senior Yellow Belt
0
Cheers spartacus - this did the trick, although I had a bit of a headache getting it to work correctly... I ended up having to modify the path value to the deployment.properties file (within deployment.config):

deployment.system.config=file\:C:/WINDOWS/Sun/Java/Deployment/deployment.properties
(deleted the backslash '\' immediately in front of 'C')

Reviewing javaw.exe's activity with Procmon revealed it was having difficulty locating the system deployment.properties file on launching the Java control panel applet, however correcting as above resolved the issue.

Thanks for pointing me in the right direction!
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ