/build/static/layout/Breadcrumb_cap_w.png

Imaging Dell Latitude 5420 Rugged with K2000

Is there anyone out there who has successfully imaged these models? An image from KACE kills the windows boot manager completely and I have to recover the OS. I then created an image from another tool and use their usb boot and it works fine. So then I created a wim and boot environment that can be used to boot with KACE's iPXE and just booting through there to the alternate boot environment kills the windows boot manager! It's like if the Latitude 5420 even suspects KACE, it turtles up and removes the boot manager. Nearly one of the weirdest things I have seen when imaging! 


It's a basic windows 10 image, no bells and whistles yet. The same exact image works just fine with older models of the rugged machines...... Either way, the image runs through the complete process like it is going to just fine and then on first reboot, bam, no hard drive detected, boot manager is gone and cannot get it back until I use the OS recovery tool. 


0 Comments   [ + ] Show comments

Answers (3)

Answer Summary:
Posted by: horacior 10 months ago
Fourth Degree Green Belt
1

Check the BIOS, I had found out with other models of new Latitude and Optiplex as well that on the boot sequence section, "Windows Boot Manager" gets unchecked after reimaging our computers, and this causes

the same behavior that you are explaining here, no hard drive detected after reimagine. I haven't found a permanent fix for this other than got back to the bios and check that box again. It is on my todo list.


Comments:
  • Thanks for the reply! Unfortunately, when it kills the boot manager it completely kills it! It isn't even there for me to check it! Fun stuff! - Brad Baker 10 months ago
  • I did get it to boot by enabling legacy boot, but it cycles through the Kace iPXE then boots the HDD through there. lol Tested it on a 5414, its predecessor and it works fine too. Just these darn 5420's! - Brad Baker 10 months ago
Posted by: Brad Baker 10 months ago
Orange Senior Belt
0

Top Answer

In order to get this to work, I had to set Secure Boot Mode, in the bios to audit mode. 
Posted by: Channeler 10 months ago
Red Belt
0

Those are UEFI only devices only.

Disable Secure Boot
Make sure you're PXE booting in UEFI Mode. (read the KBE's footer before launching your image).

make sure you are using the appropriate partitioning tasks for UEFI.

Deploy and enjoy.
See:
https://www.dell.com/support/article/en-us/sln301692/no-boot-device-found-when-you-change-the-boot-sequence-to-legacy-mode?lang=en

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ