/bundles/itninjaweb/img/Breadcrumb_cap_w.png
a bunch of components wont install upon repackaging. I get Ice38 errors but i have no reg keys in the fawlty components to set as its keypath. The files all go into Application data subfolders.

Any ideas how to go about this?

Bart [8|]
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
how about create a dummy hkcu reg to set as its keypath.. or you can "snatch" any keys on your CurrentUser component (if you have one)

rick [8D]
Answered 07/08/2005 by: rikx2
Purple Belt

Please log in to comment
0
Yup, I just make 'em up, put them in HKCU\Software\[ApplicationName], name it [component]_keypath and set the value to 1.
Answered 07/08/2005 by: VikingLoki
Second Degree Brown Belt

Please log in to comment
0
I haven't had much doing this i'm afraid.

I assigned the components to UserSettings Feature, which reinstalls for every new user. I made a "HKCU\Software\[Keypath of the component]\[component name]_keypath" regkey for each component and set it to Registry keypath

The files still don't install.
Answered 07/11/2005 by: Bartesque
Orange Senior Belt

Please log in to comment
0
not install as no? or are they placed in the root of c:?
Answered 07/11/2005 by: rikx2
Purple Belt

Please log in to comment
0
all files in question are installed to userprofile\application data\[application folder] and sub folders of this.
Answered 07/12/2005 by: Bartesque
Orange Senior Belt

Please log in to comment
0
oh .. i came to think of something ... i have before used a "fup" command ... msiexec /fup something to trigger files to be installed in user context ... can someone remember the right syntax ?
Answered 07/12/2005 by: Bartesque
Orange Senior Belt

Please log in to comment
0
Are you saying that the self-repair doesn't launch when a new user runs the application, or that the self-repair does launch but the files are not present when its completed?
Answered 07/12/2005 by: VikingLoki
Second Degree Brown Belt

Please log in to comment
0
quick question..
are the files dont get installed during install time or doesnt get repaired when self healing is triggered?


regards
rick [8D]
Answered 07/12/2005 by: rikx2
Purple Belt

Please log in to comment