/build/static/layout/Breadcrumb_cap_w.png

Software Deployment Question


I would like to do silent installation for an .exe file "Legacy Setup" "Sonic_EXPRESSfit_6.4".

10/08/2019 325 views

It has one main .EXE setup,  which calls a secondary Setup.exe at Disk1 location [along with source file]. 

In source binary folder one MSI is present but MSI has no entries in the Component, File table and it just contains few properties in it, hence triggering that MSI doesn’t seems to be working.

And also the approach of creating an MST doesn’t help here.


Troubleshooting Steps followed :

  1. Tried finding out Silent installation parameter for package , got some progress with /hide_progress parameter but not managed to do silent installation completely.

  • Test various silent parameters with both the Setup’s i.e Main and the one in the Disk1 folder

  • Silent Parameters used and also tested with multiple parameters together

  • Commands :

  • <Path of setup.exe> /S

  • <Path of setup.exe> /S /v/qn

  • <Path of setup.exe> /hide_progress  “It worked with Disk1 Setup.exe” and manage to silently install the package upto an extent but not completely.

  • <Path of setup.exe> /S /v/qr

  • <Path of setup.exe> /qn

  • <Path of setup.exe> /Quiet

  • <Path of setup.exe> /Verysilent

  • <Path of setup.exe> //hide_splash

  • <Path of Setup.exe> /s /v"/qn INSTALLDIR=D:\Destination"
  • Still need to find the Silent Switch.
  1. Response File

  • Mange to create response file with both the setup’s and tried multiple ways to install the Package with the response file but it doesn’t work

  • Test case – Used main Setup response file and tried installing package with Disk1 setup.exe and vise versa but no luck.

  • Command used “Path of Setup.exe" /s /f1"Path\Msetup.iss" and “Path of Setup.exe" -s -f1"Path\Msetup.iss"

 

  1. Captured the Application twice

  • Test Cases

  • After first snapshot launched the shortcut and then proceeded with Second snapshot but the Add-in is not coming up in Noah ”Pre-req” application.

  • Identified the two files which are responsible for Add-in ; did trial and error with those as well.

  • In captured application those two files are present but still not behaving as per source to bring the Add-In , even though tried replacing those two files in the Package INSATLLDIR but doesn’t seems to be working.

  • File name “Fit107wm” and “fit107wm.exe.manifest”.

 

  1. Used Procmon “Process Monitoring Tool” to identify the installation sequence but that also doesn't help.


I am looking into the issue but any help is highly appreciated ; i would need "Sonic_EXPRESSfit_6.4" .exe to get silently install so that it comes as an Add-on/Add-in when HIMSA_Noah_4.10.0 shortcut is launched. 


HIMSA_Noah_4.10.0 is pre-req for "Sonic_EXPRESSfit_6.4" along with .Net 3.0 or above.


Thanking you.

0 Comments   [ + ] Show comments

Comments



Community Chosen Answer

1

During the capture process, did you check that the add-in was present before completing the capture? If so, did you use the add-in? Sometimes, data doesn't get written until the application (or whatever) is actually executed.

To which folder are the add-in files installed? Are they somewhere in the user profile?

At the end of the day, applications are just a collection of files and registry data so there has to be a way to make this work.

Answered 10/09/2019 by: VBScab
Red Belt

All Answers

This content is currently hidden from public view.
Reason: Removed by member request For more information, visit our FAQ's.