/build/static/layout/Breadcrumb_cap_w.png
10/18/2018 232 views

Hello,

We currently run version 5.1 of the K2000 Deployment server and are hesitant to upgrade to version 6.0 because we know it will break pxe booting since pxe-linux is now deprecated in 6.0.

We are only imaging systems with legacy BIOS currently. No UEFI yet.


I would like to make configuration changes to continue pxe booting from legacy BIOS systems and if possible to also allow pxe booting to UEFI systems so that I can begin working on new images. Once, I can get pxe working without pxe-linux and I can deploy my existing images to legacy BIOS systems I will upgrade to K2000 6.0 and hopefully everything continues to work.

What changes need to be made on the K2000 and DHCP server etc. to reconfigure pxe and make this work?

I don't have any idea of what needs to be configured and changed.

Our DHCP is being handled by InfoBlox and we are imaging mostly Dell systems such as 90XX, 70XX, and a few old 780 and 380 systems over a LAN.


Would we need to create a new KBE or would our existing ones created earlier this year continue to work fine for our existing images?

After I switch the pxe and our existing images can still be deployed to our systems I'll begin investigating capturing/deploying UEFI images for the future. Is there an easy way to deploy an existing legacy BIOS image, switch to UEFI and then recapture as a UEFI image to simplify testing?


ITNinja has always been a great resource so I know someone will be able to provide some useful info.

Any help will be greatly appreciated.

Thanks



Answer Summary:
0 Comments   [ + ] Show comments

Comments


Answer Chosen by the Author

0
Hi,

KBEs will not be affected, they don't care about Legacy or UEFI,  or PXELINUX vs. iPXE.

If you have an Infoblox, here is the setup guide for iPXE, it was updated this year:
https://support.quest.com/kace-systems-deployment-appliance/kb/155657/how-to-setup-infoblox-pxe-to-work-with-the-kace-systems-deployment-appliance

Since version 4.0 until 5.1, the KACE SDA (formerly known as K2000) was capable of understanding both PXELinux and iPXE, but version 6 is iPXE only.

Answered 10/18/2018 by: Channeler
Red Belt

  • Thanks for that link for setting up InfoBlox. Very helpful.
    So all I have to do is switch the InfoBlox Boot entry from pxe-linux to undionly.kpxe and nothing needs to be changed on the K2000 to get this to work on legacy systems just like it is now. Then if it doesn't work I can just switch it back. Sounds simple enough.
    Another question though. How do I pxe boot from legacy and UEFI systems simultaneously since all of my images are currently legacy but I would like to begin creating UEFI based images?
    Is it possible to set the boot file to both undionly and ipxe simultaneously somehow to support both and if not how do people pxe boot legacy and UEFI systems?
    Until I have UEFI images created, I'll need to continue using the legacy images.
    Thanks again
    • Windows server DHCP 2012, 2016 and 2019 are capable of having two boot files at the same time, and request the right one to the KACE box, some older\basic DHCPs are not capable of doing this, like Windows server 2008.

      I believe those DHCPs are able to do this, because they can query the Computer's BIOS, and determine if the boot mode is set to Legacy or UEFI, after that they contact the KACE Appliance, requesting either undionly.kpxe OR ipxe.efi

      You will need to contact your DHCP vendor.

      Also, the KACE appliance has it's own built in DHCP, that is also capable of dealing with Legacy or UEFI at the same time.

      Check the Manual or contact Infoblox team to verify.

      As long as your Legacy Images are Single partition images (with C: as the only harvested partition), you should be able to deploy them as UEFI using these tasks:

      https://www.itninja.com/blog/view/bios-uefi-combined-tasks
      • Thanks, I'll check on whether InfoBlox can support two boot files. Unfortunately, both our Windows 7 and WIndows 10 images use 2 partitions, but I'll play around with it.
        Thanks again!