Can someone PLEASE tell me how I can completely disable Java Updates?  Yea I know what everyone is going ot say..WHY? its a security risk!  I could not agree with you more, but unfortunately I have no choice.  Most of our administrative departments run an older software that wants an older version of Java,  If the user is prompted or it auto updates, they unaware click on it and then the application is broken.  So I need to do the following:

Block it from updating automatically

Block it from Asking the user to update

This applies to Java 6 Update 41+ x86 and x64

and Java 7 x86 and x64


I have also looked in the Java console and see no options to disable it.



Answer Summary:
64-bit: [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy] "EnableJavaUpdate"=dword:00000000 32-bit: [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy] "EnableJavaUpdate"=dword:00000000
0 Comments   [ - ] Hide Comments


Please log in to comment

Answer this question or Comment on this question for clarity



64-bit:  [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy]


32-bit:  [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy]


Answered 11/21/2013 by: nheyne
Red Belt

  • Thanks, Creating a GPO now to test out. I will let you know how it works.
    • It should not only disable updates but remove the update tab altogether. So with this method you can't even manually update from the Java console.
      • Thanks everyone for your input. The GPO appears to work with these settings. I applied it yesterday, and for almost 24 hours we have not got a single pop up about Java.
  • This along with pushing the properties.config file with deployment.expiration.check.enabled=false set seems to be doing the trick for me
    • Great! I have never had to do more than just the reg files, but it doesn't hurt to be thorough.
      • The deployment.properties (I mistakenly called it properties.config earlier) with that line set to false prevents that pop-up window when a java applet launches and your version is past it's "expiration date" that Java has coded. So, it doesn't have to do with auto-updating but does prevent headaches for everyone.
    • Hmm that's actually a good idea, I may have to implement that!
Please log in to comment

Actually I think most people on this forum will agree with your decision. Disable updates and push them out as you need is the best option for administering your PCs. Here are the registry keys we use to disable updates:


[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy]




Answered 11/21/2013 by: jegolf
Red Belt

  • That's funny that you mirrored my post exactly, but your 64-bit example should be 0 not 1.
    • Ah - good catch! Weird as my script was right but when I copied the text using the "original editor" it was set as 1...
Please log in to comment

There are loads of posts on ITNinja, and details in the Package KB noting how to disable updates.

A combination of deployment.properties and deployment.config files, some registry settings and some properties in the MSI are generally used.

Try these few and have a search yourself:





http://www.java.com/en/download/help/java_update.xml - This one states that 64bit Java doesn't have the autoupdater included in the installer.

http://www.edugeek.net/forums/downloads/123291-java-runtime-environment-7-update-40-released-update-warning-can-now-disabled.html - This one is how to disable the update prompts in 1.7 with an entry in the deployment.properties file.


Hope that helps,


Answered 11/21/2013 by: dunnpy
Red Belt

Please log in to comment
I'm having an issue with editing the registry setting everyone is talking about here. I navigated to HKLM\Software\Javasoft\Java Update\Policy and I changed "EnableJavaUpdate" from 1 to 0. After doing this the "Update" tab is no longer visible which is great. That's what I want to happen but for whatever reason when I open up Java and view the versions the "Enabled" checkbox is not checked and it will not allow me to enable it. When I go to the Java website to verify what version of Java I have installed it says it's not installed but under "programs and features" it shows as being installed. I'm not sure why the "Enabled" checkbox is not selected. I think this is the reason why the website will not verify that the version is installed. Would you happen to know why this box becomes de-selected? Before making that one registry change the box was enabled and the website would verify version 7 update 60 installed correctly.
Answered 06/19/2014 by: pgrantland
White Belt

  • Is the install path still shown?
Please log in to comment