ftp to K1000 says existing file doesn't exist, command line is janky

In trying to restore a backup, I'm trying to remove an old backup file, but the ftp command line is janky. Here's the result:

westk@westkent:~/Downloads$ ftp jakin.acu.edu
Using binary mode to transfer files.
ftp> del 20170318_k1_base_7.0.121306.tgz
550 Could not delete 20170318_k1_base_7.0.121306.tgz: Permission denied
ftp> ls -alh
200 PORT command successful
150 Connecting to port 59295
drwxr-xr-x    3 80         0                1024 Mar 24 15:27 .
drwxr-xr-x    3 80         0                1024 Mar 24 15:27 ..
-rw-r--r--    1 80         0           512633744 Feb 25 03:00 20170225_k1_base_7.0.121306.tgz
-rw-r--r--    1 80         0               11089 Feb 25 03:00 20170225_k1_base_7.0.121306.tgz.manifest
-rw-r--r--    1 80         0            90183741 Feb 28 03:01 20170225_k1_incr_7.0.121306_20170228.tgz
-rw-r--r--    1 80         0           513522409 Mar 18 02:00 20170318_k1_base_7.0.121306.tgz
-rw-r--r--    1 80         0               11190 Mar 18 02:00 20170318_k1_base_7.0.121306.tgz.manifest
-rw-r--r--    1 80         0            99083513 Mar 24 02:02 20170318_k1_incr_7.0.121306_20170324.tgz
drwxrwxr-x    3 80         0                 512 Dec  8 05:44 autoagentrepo
lrwx------    1 80         0                  40 Mar 18 02:00 k1_base.tgz -> /kbackup/20170318_k1_base_7.0.121306.tgz
lrwx------    1 80         0                  49 Mar 24 02:02 k1_incremental.tgz -> /kbackup/20170318_k1_incr_7.0.121306_20170324.tgz
lrwx------    1 80         0                  49 Mar 24 02:02 kbox_dbdata.gz -> /kbackup/20170318_k1_incr_7.0.121306_20170324.tgz
lrwx------    1 80         0                  40 Mar 18 02:00 kbox_file.tgz -> /kbackup/20170318_k1_base_7.0.121306.tgz
226-Options: -a -l
226 13 matches total
ftp> ls -alh 20170324_k1_

In my del command, I'm specifically typing out the name of the file I'm trying to delete. But the delete command says that file does not exist. So I do an "ls -alh" to double-check that the file is there, and sure enough, the file is there. So next I do an "ls" of the specific file, using tab-completion, and it tries to tab-complete a completely different file that is not in this directory (and which I can't find anywhere).



1 Comment   [ + ] Show comment
  • Ah, just discovered something.

    "ls [tab-completion]" is listing the local directory, not the remote (as if it's "!ls"). I've never seen this before. How do I set "ls" to behave properly? - kentwest 4 years ago

Answers (2)

Answer Summary:
Posted by: KevinG 4 years ago
9th Degree Black Belt
Under Settings -> Control Panel - Security Settings  check that "Make FTP writable" is selected below "Enable backup via FTP"

  • "Make FTP writable" is selected.

    However, I'm still getting "permission denied" errors.

    I solved the "file does not exist" issue by installing and using a different ftp client. Apparently my ftp client was the part that was janky. The tab-completion (and "del" command?) was looking to the local directory instead of the remote directory. Weird. - kentwest 4 years ago
  • I didn't know what username to use for connecting via ftp, but I finally found an obscure reference somewhere (don't now recall where) that indicated I should use "kbftp", which works (except for the "permission denied" errors). Perhaps I'm supposed to use a different username? - kentwest 4 years ago
Posted by: kentwest 4 years ago
Second Degree Brown Belt

Top Answer

Since this question was focused on the ftp command line not behaving as would be expected, and a different ftp client solved that particular issue, I'm going to mark this thread as Answered, and open a new one for the specific issue of "permission denied".


Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login


This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ