/build/static/layout/Breadcrumb_cap_w.png
07/31/2019 1156 views

Hi all!

I am planning to deploy Firefox 68.0.1ESR using SCCM but I noticed that I am not able to disable automatic updates anymore.

I am using mozilla.cfg file with following settings (which have worked just fine with older FF versions):

lockPref("app.update.enabled", false);
lockPref("app.update.auto", false);
lockPref("app.update.mode", 0);
lockPref("app.update.service.enabled", false);

I also tried changing some other "app.update" settings to false but nothing helped - when opening FF -> 'About Firefox' it runs the update check.

Has anyone been able to disable this new update check feature?


Cheers!



Answer Summary:
1 Comment   [ + ] Show comment

Comments

  • Please reply to this thread, if you come up with a solution.

Answer Chosen by the Author

0

Thanks rileyz!

Looks like pref still works with FF 68.0.1ESR since I have set 'proxypac', 'trusted urls' and stuff with mozilla.cfg and these are all working as they should.

But I managed to fix the update issue with policy support --> I created policies.json file with following lines:

{
    "policies": {
    "DisableAppUpdate": true
    }
}

Then I created a folder called distribution within the Firefox installation directory and copied the policies.json into this folder.

Answered 08/01/2019 by: Hampoz
White Belt

All Answers

2

I think ESR is set by Group Policy now?
ESR uses a new policy engine.


I think the pref only work for the non-esr version.
Totally guessing here btw.

Answered 07/31/2019 by: rileyz
Red Belt