/build/static/layout/Breadcrumb_cap_w.png
03/15/2019 590 views

In some Windows 10 computers where the agent was deployed, the windows update icon appears  in status bar below showing that the windows is not updated.

I know that once the Kace agent is deployed, windows updates service is disabled automatically but the user gets noticed that windows update needs updates since when agent was installed, and some updates are managed by your administrator.

I've tried to disable it from windows services, but after a reboot, appears again after some minutes.

Is there a way to disable that icon to make this thing invisible to the user?

Thanks.

1 Comment   [ + ] Show comment

Comments

  • Thanks for the replies. Removing the icon from the notification area from the registry solved the problem.

    I've updated previously and the OS build is 17134.648



    Thanks for your help.

All Answers

1

I believe that icon is for the large feature updates for Windows?

It is trying to push a feature update depending on your Update Settings on those machines. I would check Windows Update > Advanced Options and see how long you have feature updates deferred for.

Here's the timetable for updates: https://docs.microsoft.com/en-us/windows/windows-10/release-information  -- Which version are you currently running?


And if you really want to just get rid of the icon, you can try some of the registry changes here: https://social.technet.microsoft.com/Forums/en-US/ac2b1d1c-1326-43b0-b8f0-ae7260cba3bd/disable-the-quotimportant-updates-missingquot-notification-icon-from-the-system-tray?forum=win10itprogeneral


OR just remove the icon from the notification area:


Hide_Windows_Update_Status_Icon_Taskbar_Notification_Area_Windows_10.png

Answered 03/15/2019 by: feeldamped
Second Degree Blue Belt

1

Hi
"I know that once the Kace agent is deployed, windows updates service is disabled automatically.."

This is 100% not true Ninja friend, the KACE Agent will not disable Windows Updates automatically.

In fact many people here use the KACE Patching + Windows Updates.

If you want to disable Windows Update, you can do it via GPO from the Domain Controller, or build and push via the Agent a PowerShell Script to disable Windows Updates.

If you are talking about Scripting › Configuration Policies › Windows Automatic Update, that is not useful for Win10 1709 and newer builds, works fine with 7 and 8.1 though....

Basically, unless you are manually pushing a Script to silence Windows Udpates, the KACE agent will not do it.

For example, this is the PowerShell script I use to disable WinUpdates, is not perfect... test it a dummy machine first, but it works for 1803 and older builds...

Clear-Host
$WindowsUpdatePath = "HKLM:SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\"
$AutoUpdatePath = "HKLM:SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU"
If(Test-Path -Path $WindowsUpdatePath) {
    Remove-Item -Path $WindowsUpdatePath -Recurse
}
New-Item $WindowsUpdatePath -Force
New-Item $AutoUpdatePath -Force
Set-ItemProperty -Path $AutoUpdatePath -Name NoAutoUpdate -Value 1
Get-ScheduledTask -TaskPath "\Microsoft\Windows\WindowsUpdate\" | Disable-ScheduledTask
takeown /F C:\Windows\System32\Tasks\Microsoft\Windows\UpdateOrchestrator /A /R
icacls C:\Windows\System32\Tasks\Microsoft\Windows\UpdateOrchestrator /grant Administrators:F /T
Get-ScheduledTask -TaskPath "\Microsoft\Windows\UpdateOrchestrator\" | Disable-ScheduledTask
Stop-Service wuauserv
Set-Service wuauserv -StartupType Disabled
Write-Output "All Windows Updates were disabled"
Answered 03/15/2019 by: Channeler
Red Belt