/build/static/layout/Breadcrumb_cap_w.png

Systems Deployment Question


Dell Latitude 5400 BIOS no longer supports legacy ROM's. Can these boot to the K2000 KBE without having to use a USB thumb drive?

06/14/2019 6039 views

Since the new BIOS doesn't support legacy ROM's the PXE boot option won't work. Documentation for the K2K says their DHCP should see that these computers need UEFI and boot to that environment but everything I have found online about this says you have to create a USB thumb drive to boot to UEFI and connect to the K2K before the computers can be imaged. Is there some way to network boot these to UEFI like we could to PXE?

3 Comments   [ + ] Show comments

Comments

  • We still have this issue, i have tried everything listed here, and still cannot get it to work.
    Increase the UEFI KBE Boot delay in settings - to what value? (i made it 40 sec) didn't work.
    And - boot set to uefi only no legacy - I dont see this setting anywhere in the bios.
    It was resolved read above, but this was for a single model not uefi in general - no it wasn't, i have a 5401
  • OK it was solved for his situation, that is one possible thing that could be wrong.

    What DHCP are you using? SDA's or other?

    The boot also needs drivers as well as post

    Did you download the WinPE drivers (https://www.dell.com/support/home/us/en/04/product-support/product/latitude-14-5401-laptop/drivers - Dell Command | Deploy Driver Pack) and add those to the PE driver store on the SDA, compile a new KBE that includes those and also on the SDA settings make that default?

    BTW
    My current delay is 10sec
  • We use MSDHCP, i made the change below (ipxe.efi bootfile) and got it working for the UEFI machines, but will it still work on legacy machines? if not how do i set that up?

    Thank You for your help.


Community Chosen Answer

1

You can configure your dhcp for UEFI only and switch all machines over to uefi from now on


Or if you are using MSDHCP you can set up for either bios tyoe

Answered 06/14/2019 by: SMal.tmcc
Red Belt

  • Quest says the K2000 DHCP already supports UEFI by default. The computers are being assigned IP's by the K2K but will not boot to the KBE over the network as they would with legacy.
    • Check bios for settings. Secure boot disabled, network stack uefi enabled and boot set to uefi only no legacy. Have you updated the KBE driver store with the proper WIN PE drivers for booting this model nic. Make sure the newer kbe is set to default for pxe booting in settings, Increase the UEFI KBE Boot delay in settings
      • It appears to have been an issue with the boot delay. Letting the computer go into PXE boot automatically when starting up will fail, but if I go into boot options and manually choose the same option it will work. Thanks for the help on this.
    • I can't boot into k2000 from UEFI devices, only legacy BIOS. Did anyone figure this out yet?
      • it was resolved read above, but this was for a single model not uefi in general

All Answers

0

DHCP Configuration for BIOS and UEFI PXE.

https://support.quest.com/kace-systems-deployment-appliance/kb/217556/dhcp-configuration-for-bios-and-uefi-pxe

There is a link at the bottom on how to configure MS DHCP. When I downloaded the link the file came down with no extension, if that happens just rename the file with a .pdf extension

We have cut over to UEFI and when we need to boot a legacy we either boot stick it for single machine or change the 67 DHCP entry for that subnet temporarily to legacy, boot,  then change it back when we have a group.


Answered 09/23/2019 by: SMal.tmcc
Red Belt

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ