/build/static/layout/Breadcrumb_cap_w.png

Creating Shortcuts Installshield 2008

I created 3 shortcuts using the [InstallDir] variable within Installshield 2008. When distributing the application to XP Pro via Marimba/Bladelogic the application installs and launches. The same process doesn't work on W7 and asks to fix the shortcut. If you select Fix It, the shortcut is reapaired and the application will launch without any other issues. I'm confused as to why it works on XP but not W7. Any help is much appreciated and thanks in advance.

BD

0 Comments   [ + ] Show comments

Answers (2)

Posted by: cygan 11 years ago
Fifth Degree Brown Belt
0
your shortcut variables for xp and windows 7 are different

http://technet.microsoft.com/en-us/library/dd560744%28WS.10%29.aspx


read whats on this link look for the variable CSIDL_COMMON_PROGRAMS
Posted by: bdickert 11 years ago
Senior Yellow Belt
0
This is a variable used within InstallShield [InstallDir] - differentiating from C:\Program Files (x86) (W7), C:\Program Files (W7 / 64-bit) and XP. So when the app is deployed to the workstation it will install to the appropriate folders mentioned above. Sorry for the confusion.

BD
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ