/build/static/layout/Breadcrumb_cap_w.png

Captivate 9 Silent Install, disabling adobe product improvement program

I'm trying to create a silent install for Captivate 9, and it's easy enough using their creative cloud packager.  The problem is the first time people open the application the product improvement program pops up saying they're participating and asks if they want to continue to participate or stop participating.  In an enterprise environment where we're deploying this to a hundred people this doesn't work, this needs to be turned off by default and not confuse our users. 

The key for this is here HKEY_CURRENT_USER\Software\Adobe\CommonFiles\Usage\Adobe Captivate\OptIn=1.  That key doesn't get created during program installation it gets created after the user opens the application the first time, so how do we disable it?  I'm unable to find where it's getting that setting from.

Thanks


0 Comments   [ + ] Show comments

Answers (4)

Answer Summary:
Posted by: Pressanykey 5 years ago
Red Belt
1

Top Answer

Hi,
that's a classic Active Setup solution. Create an Active Setup entry that write the registry key and value and your done.
If you search this site regarding Active Setup you should find enough information.

Phil

Comments:
  • I tried using Active Setup but it doesn't work. I created the registry entries and when the user logs in it executes the command I want and creates the registry key properly. But when the user opens Captivate the first time it overwrites those settings and turns the product improvement program back on.

    I also tried creating the key under HKLM but that doesn't work either. - EricD 5 years ago
    • I believe I have this working properly now with Active Setup. I have to export/import the entire [HKEY_CURRENT_USER\Software\Adobe] key for this to work though - EricD 5 years ago
Posted by: apptopack 5 years ago
Red Belt
0

Phil is correct. Use Active Setup for this case. It will run once when a user logs in.

NOTE: If installed through system context a logoff is required before launching the shortcut.

Posted by: Badger 5 years ago
Red Belt
0

Have you tried creating the same key but in a machine location?? that sometimes work for Adobe products.

 

Posted by: mrphr34k 5 years ago
White Belt
0
You will need to create a firstLaunch.txt file before you open Captivate.
C:\Users\XXX\AppData\Local\Adobe\Captivate 9.0\firstLaunch.txt



I used PowerShell to get this done.  Here is my code.

ForEach ($User in (Get-ChildItem "C:\Users" | where {$_.Attributes -Eq 'Directory'})) 
{
    New-Item "C:\Users\$($User.Name)\AppData\Local\Adobe\Captivate 9.0\firstLaunch.txt" -type file -Force
}

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ