/build/static/layout/Breadcrumb_cap_w.png

Systems Deployment Question


Can't make the Autologon working

12/05/2019 204 views

Hello everyone,

I have an autologon problem, and it begins to piss me off.

I try to run a scripted install of the W10 1903.

In my Unattend.xml, I have set up an autologon with login and password, and add this account (local account) directly in the Administrators group of th machine.

But after the driver installation, the computer rebbots and says that credentials are wrong.

Whereas they are good because I can login just after with them, and the deployment continues...

I have tried to add in "Specialize" pass, the lines:

<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <RunSynchronous>
        <RunSynchronousCommand wcm:action="add">
          <Description>EnableAdmin</Description>
          <Order>1</Order>
          <Path>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoAdminLogon /t REG_SZ /d 1 /f</Path>
        </RunSynchronousCommand>
        <RunSynchronousCommand wcm:action="add">
          <Description>DefaultUserName</Description>
          <Order>2</Order>
          <Path>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultUserName /t REG_SZ /d .\loginhere/f</Path>
        </RunSynchronousCommand>
        <RunSynchronousCommand wcm:action="add">
          <Description>DefaultPassword</Description>
          <Order>3</Order>
          <Path>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultPassword /t REG_SZ /d passwordhere</Path>
        </RunSynchronousCommand>
      </RunSynchronous>
    </component>

DO you have any idea to help me please ?

Thanks a lot.


3 Comments   [ + ] Show comments

Comments

  • Are you using VL media?
  • Yes I use a VL W10 media. The installation is fine, just the autologon n working after the image is applied.
    I have to logon manually to let the deployment continue...
  • Hello, I also tried this, but it still says that creadentials are not correct:

    <settings pass="oobeSystem">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
    <OOBE>
    <HideEULAPage>true</HideEULAPage>
    <NetworkLocation>Other</NetworkLocation>
    <SkipMachineOOBE>false</SkipMachineOOBE>
    <SkipUserOOBE>false</SkipUserOOBE>
    <ProtectYourPC>3</ProtectYourPC>
    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
    </OOBE>
    <UserAccounts>
    <LocalAccounts>
    <LocalAccount wcm:action="add">
    <Name>ADMINRELYENS</Name>
    <Group>Administrators</Group>
    <Password>
    <Value>passwordhere</Value>
    <PlainText>true</PlainText>
    </Password>
    </LocalAccount>
    </LocalAccounts>
    </UserAccounts>
    <FirstLogonCommands>
    <SynchronousCommand wcm:action="add">
    <Order>1</Order>
    <CommandLine>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoAdminLogon /t REG_SZ /d 1 /f</CommandLine>
    </SynchronousCommand>
    <SynchronousCommand wcm:action="add">
    <Order>2</Order>
    <CommandLine>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultUserName /t REG_SZ /d .\ADMINRELYENS/f</CommandLine>
    </SynchronousCommand>
    <SynchronousCommand wcm:action="add">
    <Order>3</Order>
    <CommandLine>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultPassword /t REG_SZ /d passwordhere</CommandLine>
    </SynchronousCommand>
    </FirstLogonCommands>
    </component>

All Answers

1

you have to put this in your unattend.xml in the following section  <settings pass="specialize">

    <AutoLogon>
        <Enabled>true</Enabled>
        <Username>enableAdmin</Username>
        <Password>
          <PlainText>true</PlainText>
          <Value>yourPassword</Value>
        </Password>
        <LogonCount>1</LogonCount>
   </AutoLogon>


https://docs.microsoft.com/en-us/windows-hardware/customize/desktop/unattend/microsoft-windows-shell-setup-autologon

Answered 12/10/2019 by: Gerhart
Third Degree Blue Belt

  • Hello,
    I already have this section in my Specialize area, but it does not work.
    <settings pass="specialize">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
    <RegisteredOwner>OrganizationName</RegisteredOwner>
    <RegisteredOrganization>OrganizationName</RegisteredOrganization>
    <ProductKey>W269N-WFGWX-YVC9B-4J6C9-T83GX</ProductKey>
    <TimeZone>Romance Standard Time</TimeZone>
    <ComputerName>*</ComputerName>
    <AutoLogon>
    <Enabled>true</Enabled>
    <Username>login</Username>
    <Password>
    <PlainText>true</PlainText>
    <Value>passwordvalue</Value>
    </Password>
    <LogonCount>2</LogonCount>
    </AutoLogon>
    </component>


    The computer reboots and tells that credentials are not correct.
    Is there another way (registry keys) to implement the autologon in the specialize section ?

    Thanks.
    • Usually you do not have to add registry keys for automatic login to work. All you need is the section <autologon> in unattend.xml

      can you post the complete xml (without PW and user information) here? then I can check the whole syntax.
      • <?xml version="1.0" encoding="utf-8"?>
        <unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <settings pass="windowsPE">
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
        <UseConfigurationSet>true</UseConfigurationSet>
        <ImageInstall>
        <OSImage>
        <InstallFrom>
        <MetaData wcm:action="add">
        <Key>/IMAGE/INDEX</Key>
        <Value>5</Value>
        </MetaData>
        </InstallFrom>
        <InstallToAvailablePartition>true</InstallToAvailablePartition>
        </OSImage>
        </ImageInstall>
        <UserData>
        <AcceptEula>true</AcceptEula>
        <FullName>OrganizationName</FullName>
        <Organization>OrganizationName</Organization>
        </UserData>
        </component>
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
        <UILanguage>en-US</UILanguage>
        <SetupUILanguage>
        <UILanguage>en-US</UILanguage>
        </SetupUILanguage>
        <InputLocale>fr-FR</InputLocale>
        <SystemLocale>fr-FR</SystemLocale>
        <UserLocale>fr-FR</UserLocale>
        </component>
        </settings>
        <settings pass="specialize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
        <RegisteredOwner>OrganizationName</RegisteredOwner>
        <RegisteredOrganization>OrganizationName</RegisteredOrganization>
        <ProductKey>W269N-WFGWX-YVC9B-4J6C9-T83GX</ProductKey>
        <TimeZone>Romance Standard Time</TimeZone>
        <ComputerName>*</ComputerName>
        <AutoLogon>
        <Enabled>true</Enabled>
        <Username>adminlogin</Username>
        <Password>
        <PlainText>true</PlainText>
        <Value>passwordvalue</Value>
        </Password>
        <LogonCount>2</LogonCount>
        </AutoLogon>
        </component>
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
        <Identification>
        <JoinDomain>Domain</JoinDomain>
        <Credentials>
        <Domain>Domain</Domain>
        <Username>domainLogin</Username>
        <Password>passwordvalue</Password>
        </Credentials>
        </Identification>
        </component>
        <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
        <RunSynchronous>
        <RunSynchronousCommand wcm:action="add">
        <Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
        <Description>Setting Network Location</Description>
        <Order>1</Order>
        <WillReboot>OnRequest</WillReboot>
        </RunSynchronousCommand>
        <RunSynchronousCommand wcm:action="add">
        <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v EnableFirstLogonAnimation /d 0 /t REG_DWORD /f</Path>
        <Description>Hide First Logon Animation</Description>
        <Order>2</Order>
        </RunSynchronousCommand>
        <RunSynchronousCommand wcm:action="add">
        <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /v EnableFirstLogonAnimation /d 0 /t REG_DWORD /f</Path>
        <Description>Hide First Logon Animation</Description>
        <Order>3</Order>
        </RunSynchronousCommand>
        </RunSynchronous>
        </component>
        </settings>
        <settings pass="oobeSystem">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
        <OOBE>
        <HideEULAPage>true</HideEULAPage>
        <NetworkLocation>Other</NetworkLocation>
        <SkipMachineOOBE>false</SkipMachineOOBE>
        <SkipUserOOBE>false</SkipUserOOBE>
        <ProtectYourPC>3</ProtectYourPC>
        <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
        <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
        <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
        </OOBE>
        <UserAccounts>
        <LocalAccounts>
        <LocalAccount wcm:action="add">
        <Name>adminlogin</Name>
        <Group>Administrators</Group>
        <Password>
        <Value>passwordvalue</Value>
        <PlainText>true</PlainText>
        </Password>
        </LocalAccount>
        </LocalAccounts>
        </UserAccounts>
        <FirstLogonCommands>
        <SynchronousCommand wcm:action="add">
        <Order>1</Order>
        <CommandLine>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoAdminLogon /t REG_SZ /d 1 /f</CommandLine>
        </SynchronousCommand>
        <SynchronousCommand wcm:action="add">
        <Order>2</Order>
        <CommandLine>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultUserName /t REG_SZ /d .\adminlogin /f</CommandLine>
        </SynchronousCommand>
        <SynchronousCommand wcm:action="add">
        <Order>3</Order>
        <CommandLine>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultPassword /t REG_SZ /d passwordvalue</CommandLine>
        </SynchronousCommand>
        <SynchronousCommand wcm:action="add">
        <Order>4</Order>
        <CommandLine>REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoLogonCount /t REG_SZ /d 2</CommandLine>
        </SynchronousCommand>
        </FirstLogonCommands>
        </component>
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
        <InputLocale>fr-FR</InputLocale>
        <SystemLocale>fr-FR</SystemLocale>
        <UILanguage>fr-FR</UILanguage>
        <UserLocale>fr-FR</UserLocale>
        </component>
        </settings>
        </unattend>

        Thanks for your time to help me !
        Also, when I log on for the first time, I have the "Disable UAC" task in Failure. Indeed, when I check the registry key, enablelua that the vbs trys to access, this key does not exist...
    • Sorry, i can not wrote a reply on your last comment. so i will post it here.

      In your xml is no big difference to mine with one exception.
      I dont have a part <FirstLogonCommands>
      can you try the xml without this part?

      like this:
      <?xml version="1.0" encoding="utf-8"?>
      <unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <settings pass="windowsPE">
      <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <UseConfigurationSet>true</UseConfigurationSet>
      <ImageInstall>
      <OSImage>
      <InstallFrom>
      <MetaData wcm:action="add">
      <Key>/IMAGE/INDEX</Key>
      <Value>5</Value>
      </MetaData>
      </InstallFrom>
      <InstallToAvailablePartition>true</InstallToAvailablePartition>
      </OSImage>
      </ImageInstall>
      <UserData>
      <AcceptEula>true</AcceptEula>
      <FullName>OrganizationName</FullName>
      <Organization>OrganizationName</Organization>
      </UserData>
      </component>
      <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <UILanguage>en-US</UILanguage>
      <SetupUILanguage>
      <UILanguage>en-US</UILanguage>
      </SetupUILanguage>
      <InputLocale>fr-FR</InputLocale>
      <SystemLocale>fr-FR</SystemLocale>
      <UserLocale>fr-FR</UserLocale>
      </component>
      </settings>
      <settings pass="specialize">
      <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <RegisteredOwner>OrganizationName</RegisteredOwner>
      <RegisteredOrganization>OrganizationName</RegisteredOrganization>
      <ProductKey>W269N-WFGWX-YVC9B-4J6C9-T83GX</ProductKey>
      <TimeZone>Romance Standard Time</TimeZone>
      <ComputerName>*</ComputerName>
      <AutoLogon>
      <Enabled>true</Enabled>
      <Username>adminlogin</Username>
      <Password>
      <PlainText>true</PlainText>
      <Value>passwordvalue</Value>
      </Password>
      <LogonCount>2</LogonCount>
      </AutoLogon>
      </component>
      <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <Identification>
      <JoinDomain>Domain</JoinDomain>
      <Credentials>
      <Domain>Domain</Domain>
      <Username>domainLogin</Username>
      <Password>passwordvalue</Password>
      </Credentials>
      </Identification>
      </component>
      <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <RunSynchronous>
      <RunSynchronousCommand wcm:action="add">
      <Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
      <Description>Setting Network Location</Description>
      <Order>1</Order>
      <WillReboot>OnRequest</WillReboot>
      </RunSynchronousCommand>
      <RunSynchronousCommand wcm:action="add">
      <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v EnableFirstLogonAnimation /d 0 /t REG_DWORD /f</Path>
      <Description>Hide First Logon Animation</Description>
      <Order>2</Order>
      </RunSynchronousCommand>
      <RunSynchronousCommand wcm:action="add">
      <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /v EnableFirstLogonAnimation /d 0 /t REG_DWORD /f</Path>
      <Description>Hide First Logon Animation</Description>
      <Order>3</Order>
      </RunSynchronousCommand>
      </RunSynchronous>
      </component>
      </settings>
      <settings pass="oobeSystem">
      <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <OOBE>
      <HideEULAPage>true</HideEULAPage>
      <NetworkLocation>Other</NetworkLocation>
      <SkipMachineOOBE>false</SkipMachineOOBE>
      <SkipUserOOBE>false</SkipUserOOBE>
      <ProtectYourPC>3</ProtectYourPC>
      <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
      <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
      <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
      </OOBE>
      <UserAccounts>
      <LocalAccounts>
      <LocalAccount wcm:action="add">
      <Name>adminlogin</Name>
      <Group>Administrators</Group>
      <Password>
      <Value>passwordvalue</Value>
      <PlainText>true</PlainText>
      </Password>
      </LocalAccount>
      </LocalAccounts>
      </UserAccounts>
      </component>
      <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
      <InputLocale>fr-FR</InputLocale>
      <SystemLocale>fr-FR</SystemLocale>
      <UILanguage>fr-FR</UILanguage>
      <UserLocale>fr-FR</UserLocale>
      </component>
      </settings>
      </unattend>
      • Yes, that what I had before trying to add the registry keys for autologon.
        It does not work =s

        Do you know if there is a way to force the autologon in the specializepass ?
  • Sorry, i dont know any other way in unattend.xml File.

    You can use the Windows ADK System Image Manager to validate your .xml. Maybe it is a unseen error in Syntax.

    Read this Articel in itninja
    https://www.itninja.com/blog/view/validating-unattend-xml-files-with-system-image-manager

    If I find some time, I will try the xml in my test environment.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ