/build/static/layout/Breadcrumb_cap_w.png

AlwaysInstallElevated not working 100%

I have a couple of MSI applications that will not install on a PC with Non-admin user rights. I have the registry keys in for making the MSI install with elevated rights but it won't install. I have figured it out that it pertains to folder permissions in the Program Files directory. I am wanting to know Why an MSI will fail install when it has the AlwaysInstallElevated registry keys? Can anyone shed some light on this? I appreciate any responses.

Thank you.

John Summers
ING Direct, fsb

0 Comments   [ + ] Show comments

Answers (3)

Posted by: phanigudivada 9 years ago
Purple Belt
0

the registry should be in os, not in MSI

Posted by: cdupuis 17 years ago
Third Degree Green Belt
0
Try changing the default install path to something other than Program Files. Let me know if that works, then we can look at the permissions it requires.
Posted by: MSIMaker 17 years ago
2nd Degree Black Belt
0
If it is a vendor msi then check the custom actions to make sure they are running in System Context.
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ