/build/static/layout/Breadcrumb_cap_w.png
12/14/2018 734 views

Good afternoon to all.

I'm trying to install the brand new 9.0.168 agent bundle without success. I've read the KB on Quest's support (https://support.quest.com/kace-systems-management-appliance/kb/264212/agent-bundle-update-available) and I can see in update log:

[Fri Dec 14 14:18:23 CET 2018] [kbin:signature] 2e22709d0e390208529e77d5f4a365e1dac6efc4af975f1cba666ee441aba22988ada3293540b06f6bb4734ad00c6aeaa6972015aecfc99b7ac5053ad025ac0b
[Fri Dec 14 14:18:23 CET 2018] [kbin:bundle:apply] k1000_agents_9.0.168.kbin
[Fri Dec 14 14:18:26 CET 2018] [notice] Agent upload complete.

but in the Update Agent Settings section I see the older version:


Am I doing something wrong?

Thanks in advance and have a nice day.

G

Answer Summary:
0 Comments   [ + ] Show comments

Comments


Answer Chosen by the Author

1

same problem here is shows in the system root as 9.0.168 and the orgs show there is an update.  When I click on apply it goes thru the paces like it doing it but never gets applied.  I opened file explorer to the \\kbox\client_3\agent_provisioning\windows_platform directory deleted  the existing updates and cleared the old version out.  I then applied the new one and it created the file structure with the old client again.  have tested with both IE and FF and neither will apply the update.


Answered 12/14/2018 by: SMal.tmcc
Red Belt

  • "I opened file explorer to the \\kbox\client_3\agent_provisioning\windows_platform directory deleted the existing updates and cleared the old version out. I then applied the new one and it created the file structure with the old client again. have tested with both IE and FF and neither will apply the update."
    --

    Same test here with the identically result. I have tried to open a ticket on Quest Support's Page but we have problem with license renewal (I've sent a mail to Renewal Support) ;-(
    • got an answer on Kace:slack. see

      https://support.quest.com/kace-systems-management-appliance/kb/264212/agent-bundle-update-available

      IMPORTANT NOTE: The agent version itself will not change and the Available Agent Bundle section will always show the newer version available, even after clicking apply. This is expected behavior. See below for instructions to ensure the changes applied properly.

      inspect your MSI and look at it's certificate
      if it expires in 2021, you're good
      • Good, not very clear in the KB but now here we are. The certificate on the MSI I have downloaded expires on 2021, I have substituted it to my old one.

        Thanks Smal :-)
      • I can't get the new bundle through Appliance Updates. I manually downloaded the bundle from Quest but can't get it to apply. Is anyone else having the same issues?
      • it will look like it never applied but it does. Look at the \\kbox\client\agent_provisioning\windows_platform directory date stamp. Is it the time when you applied the update? mine shows 12/14/18 7:39 so it recreated the structure. If the date is correct go look at msi file. right click and choose properties - digital signatures. highlight the name of signer and click on details, click on view certificates and see if it expires 10/30/2021
      • My date hasn't changed from when I did the 9.0 upgrade. I was able to extract the agent bundle I downloaded to get the new .msi. I will replace what my GPO uses with this one. Hopefully the K1000 will get the update also. The immediate issue is resolved with extracting the msi from the agent bundle. Thanks for the reply.
      • Dear Quest, this isn't how version numbers work.
    • you have some other problem then. My update did show in the system settings also. note:(I have multi org)
      Agent Available Version: 9.0.168 [Release Notes]
      • My K1000 acquired the agent bundle overnight and I applied it this morning. That's the first time I have had an issue where I could not manually upload and apply a kbin. Thanks for the time.

All Answers

2

the new agent bundle still has the old build number, just a renewed certificate.
For agents which are already installed there is nothing to do.
If you need to install a new agent the certificate needs to be valid or the OS will notify the expired certificate or deny the installation depending on the settings.
To prevent to reinstall the agent the version number did not increment.

This unfortunately shows you the info that a newer one is avaiable.
Final solution would be the 9.1 as soon as it is released ;)

Answered 12/16/2018 by: Nico_K
Red Belt

  • Thanks! :-)