/build/static/layout/Breadcrumb_cap_w.png

A Wise "gotcha"

I was just replying to a post which mentioned the sequence of actions in an MSI. That reminded me that for ages I've been meaning to post about something I noticed in WPS v7 which caught me out. That is, sometimes if you move CAs around in the UI using cut-and-paste, the sequencing gets completely screwed. This may not be a problem most of the time but most definitely IS a problem when you're setting a property which is to be used by a deferred CA i.e. one which populates the special CustomActionData property. For whatever reason, WPS would set the property-setting CA's sequence to be after the CA which relies on it. Of course, it's easy enough to fix by editing the sequence table, but the first time it happened, it took me a few debug runs before the penny dropped!

0 Comments   [ + ] Show comments

Answers (1)

Posted by: mekaywe 11 years ago
Brown Belt
0
Yes., many a times it happens and will cause peculiar problems not frequently though.
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Don't be a Stranger!

Sign up today to participate, stay informed, earn points and establish a reputation for yourself!

Sign up! or login

Share

 
This website uses cookies. By continuing to use this site and/or clicking the "Accept" button you are providing consent Quest Software and its affiliates do NOT sell the Personal Data you provide to us either when you register on our websites or when you do business with us. For more information about our Privacy Policy and our data protection efforts, please visit GDPR-HQ