So I have this app. Everything works except one issue. I get a "Windows Firewall has Blocked" message when first launching it. I go to create a GPO to allow it, and it appears that the directory changes for every user. The exe exists in "%localappdata%\apps\2.0" plus a random string of characters. I've tried entering the usual wildcards. I've also tried just the exe name, and just the %localappdata%\apps\2.0 directory. Nothing seems to work. Any thoughts?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0
this guy has one to block all exe's in a dir and all subdirs, Looks like it can modified to allow instead of block

would this idea work for you to do allow all exe's below the 2.0 directory

https://sites.google.com/site/mytools4000/home/allow-block-multiple-programs-through-windows-7-firewall/

@echo off
REM      BATCH FILE CREATED BY CHARLES DE HAVILLAND 20/02/2012
cls
If "%1"=="" GOTO :norulename
SET RULENAME=%1
ECHO Create in/out firewall rules for all *.exe files with the rulename of "%RULENAME%" ?
ECHO.
ECHO.

pause
Echo.
FOR /r %%G in ("*.exe") Do (@echo %%G
NETSH advfirewall firewall add rule name="%RULENAME%-%%~nxG" dir=in program="%%G" action="block" enable="yes")
FOR /r %%G in ("*.exe") Do (@echo %%G
NETSH advfirewall firewall add rule name="%RULENAME%-%%~nxG" dir=out program="%%G" action="block" enable="yes")
Echo.
Echo done.
Echo.
GOTO :Finish
:norulename
Echo Error! - You did not specify a Rulename type - Addfwrs "Rulename"
Echo.
:Finish
Echo Batch ended...
Answered 08/21/2014 by: SMal.tmcc
Red Belt

  • I actually saw this same link, and tried it. It will work, but unfortunately the directory doesn't exist on the users profile until the launch the app. When a new user first launches the app, it does a check with the server. It then creates the dir, and all of the files.
    • can you create a short cut to the app that calls a batch file to launch the app then run that script?
      • I'm looking into that now. This is a very strange app. After getting the firewall popup I hit cancel. After I relaunch the app I never get prompted again. I check the firewall rules, and the rule is there. I'll need to test functionality of the app still, but for some strange reason this may work.
      • that is weird behavior!
Please log in to comment
Answer this question or Comment on this question for clarity