I have a specific group of machines that don't seem to stay awake. I send Wake on LAN requests to them, they wake up, and then sleep again after only a few minutes.

I have checked the power settings for the machines, and they are configured to sleep at 60 minutes.

If I RDP to one of the machines, it stays awake.

Does anybody have any idea what could be going on here? 

Answer Summary:
reconfigure power settings as directed here http://www.vistax64.com/tutorials/171042-sleep-return-timeout-unattended-wake-up.html reboot of system is required
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

3

since no one is logged in it probably is defaulting to the default power plan of 120 seconds

http://support.microsoft.com/kb/810719/en-us

Answered 02/04/2013 by: SMal.tmcc
Red Belt

  • look at this link, maybe changing these keys will work for you
    http://www.vistax64.com/tutorials/171042-sleep-return-timeout-unattended-wake-up.html
  • added registry keys as such:

    reg add HKLM\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues\381b4222-f694-41f0-9685-ff5bb260df2e /v AcSettingIndex /t REG_DWORD /d 1800 /f

    reg add HKLM\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues\381b4222-f694-41f0-9685-ff5bb260df2e /v DcSettingIndex /t REG_DWORD /d 1800 /f

    Systems are using the balanced plan.

    Systems still go back to sleep after waking up. very confused, figured this would be a sure thing.
    • I did to, do you use deepfreeze and have any options set in it.
      • I don't use deepfreeze
      • The setting seems to require a system reboot. Added registry keys, and only after a reboot did it seem to take effect.
Please log in to comment
Answer this question or Comment on this question for clarity