After deploying our windows 7 image (sysprep'd) we are unable to get the offline files service working. The service will not start (Error 3: The system cannot find the path specified) It seems like the imagedeploy (=filecopy) corrupts the offline files database.

The machine from which we captured the image works fine, no problem with the offline files service.

I created several new images always resulting in a corrupted offline files database when deployed with kace.

Are there specific steps needed to capture and deploy win 7 ?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
We've had the same problem and haven't found a solution. There are ways to re-format the offline file area. Sometimes it works and sometimes it doesn't. Please post if you find any information.
Answered 12/14/2010 by: bgatech
Orange Senior Belt

Please log in to comment
0
Here's some advice from our QA folks:

Offline Files is a very picky service. I'm using it on my computer and I'm constantly having to tweak and fiddle with it to get it to sync. If possible, it would be better to create an image without offline files configured and then configure Offline files in group policy http://technet.microsoft.com/en-us/library/cc759721%28WS.10%29.aspx [or maybe using K1000 scripting --jk]

Here are a few things to try on one of the imaged machines that isn't working. This will help identify where the problem is.
  1. Locate the cscsvc.dll file under the folder C:\Windows\System32. Remove the one on the system that's not working and replace with a copy from a working system.
  2. Navigate the following registry key on another Windows 7 machine and export it. Then, copy and import it on the problematic machine. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\CscService
  3. Run System File Checker (SFC) to identify and repair any corrupted system files.
Answered 12/17/2010 by: jkatkace
Purple Belt

Please log in to comment
0
So having the same issue I have come across two fixes.

1) Disable Offline Files before imaging
2) If system is already deployed run this line and reboot. REG ADD "HKLM\System\CurrentControlSet\Services\CSC\Parameters" /v FormatDatabase /t REG_DWORD /d 1 /f
Not elegant but it works.
I hope this helps someone.
Answered 02/01/2012 by: d_firlotte
Orange Belt

Please log in to comment
0
We have discovered a new problem with this issue. My previous post of the registry entry to format database works for the specific issue but we found another issue with Lenovo laptops. If you have the utiltity RapidBoot installed and you plan on using Offline Files remove the utility. With the two items running on the same workstation offline files will not start automatically and even if you do start the service it has issues with syncing and upon reboot the service will not start again.

Hope that helps
Answered 03/22/2012 by: d_firlotte
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share