How do I prevent a Win7 scripted installation from prompting to input a User account and Password? I have the Administrator name and password set in the answer file but I still get prompted for a new user account.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
It has to be an improperly configured answer file. Did you create your own or use the wizard to create one for you?
Answered 03/31/2011 by: airwolf
Tenth Degree Black Belt

Please log in to comment
0
Used the KACE wizard
Answered 03/31/2011 by: ronellis10
Senior Yellow Belt

Please log in to comment
0
Paste your answer file here and I can try to figure out the problem. Feel free to change the password to something generic like "password" for security reasons. Also, pull out your license key if it's in there somewhere.
Answered 03/31/2011 by: airwolf
Tenth Degree Black Belt

Please log in to comment
0
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<settings pass="windowsPE">
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<UseConfigurationSet>true</UseConfigurationSet>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>Vantium Capital</FullName>
<Organization>Vantium capital</Organization>
<ProductKey>
<Key>22ABC-33XYZX-5VJC7-G9998-SDHJK</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
<ImageInstall>
<OSImage>
<InstallToAvailablePartition>true</InstallToAvailablePartition>
<InstallFrom>
<MetaData>
<Key>/IMAGE/Name</Key>
<Value>windows 7 enterprise</Value>
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>
</component>
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<UILanguage>en-US</UILanguage>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>en-us</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UserLocale>en-us</UserLocale>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<RegisteredOwner>Vantium Capital</RegisteredOwner>
<RegisteredOrganization>Vantium capital</RegisteredOrganization>
<ProductKey>22ABC-33XYZX-5VJC7-G9998-SDHJK</ProductKey>
<TimeZone>Central Standard Time</TimeZone>
<AutoLogon>
<Enabled>true</Enabled>
<Username>Administrator</Username>
<Password>
<PlainText>true</PlainText>
<Value>Password</Value>
</Password>
<LogonCount>3</LogonCount>
</AutoLogon>
<ComputerName>*</ComputerName>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<Identification>
<JoinWorkgroup>WORKGROUP</JoinWorkgroup>
</Identification>
</component>
<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
<Description>Setting Network Location</Description>
<Order>1</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
</RunSynchronous>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Work</NetworkLocation>
<SkipMachineOOBE>false</SkipMachineOOBE>
<SkipUserOOBE>false</SkipUserOOBE>
<ProtectYourPC>3</ProtectYourPC>
</OOBE>
<UserAccounts>
<AdministratorPassword>
<Value>Password</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
</unattend>
Answered 03/31/2011 by: ronellis10
Senior Yellow Belt

Please log in to comment
0
Hmm... I don't see anything wrong at first glance. Are you sure the correct "type" was selected in this section? It will only work if you're installing Windows 7 Enterprise.

<ImageInstall>
<OSImage>
<InstallToAvailablePartition>true</InstallToAvailablePartition>
<InstallFrom>
<MetaData>
<Key>/IMAGE/Name</Key>
<Value>windows 7 enterprise</Value>
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>
Answered 03/31/2011 by: airwolf
Tenth Degree Black Belt

Please log in to comment
0
Yes - we are installing Windows 7 Enterprise SP1 but I am also having the same issue with non-SP1 both 32 and 64 bit versions
Answered 03/31/2011 by: ronellis10
Senior Yellow Belt

Please log in to comment
0
Ronellis10,

Try copying this component in place of your "Microsoft-Windows-Deployment" component. The only difference is that I put another <runSynchronousCommand> of enabling the Administrator account. By default, Windows 7 disables this account. Since it is disabled, it won't autologon, and there are no other accounts that you created, therefore it needs an account to login to. This will enabled the Administrator account so that the autologon will work.

<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
<Description>Setting Network Location</Description>
<Order>1</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>net user administrator /active:yes</Path>
<Order>1</Order>
</RunSynchronousCommand>
</RunSynchronous>
</component>
Answered 04/03/2011 by: cserrins
Red Belt

Please log in to comment
0
I tried your suggestion and now I get an error:

Install Windows pop-up
Windows could not parse or process unattended answer file [C:\windows\panther\unattended.xml] for pass [specialize]. A component or setting in the answer file does not exist.

Here is my current answer file:
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<settings pass="windowsPE">
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<UseConfigurationSet>true</UseConfigurationSet>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>Vantium Capital</FullName>
<Organization>Vantium Capital</Organization>
<ProductKey>
<Key>33PXH-99999-99999-99999-99999</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
<ImageInstall>
<OSImage>
<InstallToAvailablePartition>true</InstallToAvailablePartition>
</OSImage>
</ImageInstall>
</component>
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<UILanguage>en-US</UILanguage>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>en-us</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UserLocale>en-us</UserLocale>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<RegisteredOwner>Vantium Capital</RegisteredOwner>
<RegisteredOrganization>Vantium Capital</RegisteredOrganization>
<ProductKey>33PXH-99999-99999-99999-99999</ProductKey>
<TimeZone>Central Standard Time</TimeZone>
<AutoLogon>
<Enabled>true</Enabled>
<Username>Administrator</Username>
<Password>
<PlainText>true</PlainText>
<Value>xxxxxx1</Value>
</Password>
<LogonCount>3</LogonCount>
</AutoLogon>
<ComputerName>*</ComputerName>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<Identification>
<JoinWorkgroup/>
</Identification>
</component>
<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
<Description>Setting Network Location</Description>
<Order>1</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<Path>net user administrator /active:yes</Path>
<Order>1</Order>
</RunSynchronous>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Work</NetworkLocation>
<SkipMachineOOBE>false</SkipMachineOOBE>
<SkipUserOOBE>false</SkipUserOOBE>
<ProtectYourPC>3</ProtectYourPC>
</OOBE>
<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Name>Vantium</Name>
<Group>Administrators</Group>
<Password>
<Value>xxxxxx1</Value>
<PlainText>true</PlainText>
</Password>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
</component>
</settings>
</unattend>
Answered 04/06/2011 by: ronellis10
Senior Yellow Belt

Please log in to comment
0
You didn't copy/paste what I had. I'm not 100% that you need to seperate the <RunSyncronous> commands or not, but you have an extra </RunSyncronous> in your xml file. Also, you may want to edit your product key and passwords out from the forum.
Answered 04/06/2011 by: cserrins
Red Belt

Please log in to comment
0
I have redone the script, copied in what you sent me and I still get the same error I submitted today. Here is the updated script:

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<settings pass="windowsPE">
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<UseConfigurationSet>true</UseConfigurationSet>
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>Vantium Capital</FullName>
<Organization>Vantium Capital</Organization>
<ProductKey>
<Key>99999-99999-99999-99999-99999</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
<ImageInstall>
<OSImage>
<InstallToAvailablePartition>true</InstallToAvailablePartition>
</OSImage>
</ImageInstall>
</component>
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<UILanguage>en-US</UILanguage>
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>en-us</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UserLocale>en-us</UserLocale>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<RegisteredOwner>Vantium Capital</RegisteredOwner>
<RegisteredOrganization>Vantium Capital</RegisteredOrganization>
<ProductKey>99999-99999-99999-99999-99999</ProductKey>
<TimeZone>Central Standard Time</TimeZone>
<AutoLogon>
<Enabled>true</Enabled>
<Username>Administrator</Username>
<Password>
<PlainText>true</PlainText>
<Value>XXXXXXX1</Value>
</Password>
<LogonCount>3</LogonCount>
</AutoLogon>
<ComputerName>*</ComputerName>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<Identification>
<JoinWorkgroup/>
</Identification>
</component>
<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Path>reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\FirstNetwork" /v Category /t REG_DWORD /d 00000000 /f</Path>
<Description>Setting Network Location</Description>
<Order>1</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>net user administrator /active:yes</Path>
<Order>1</Order>
</RunSynchronousCommand>
</RunSynchronous>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Work</NetworkLocation>
<SkipMachineOOBE>false</SkipMachineOOBE>
<SkipUserOOBE>false</SkipUserOOBE>
<ProtectYourPC>3</ProtectYourPC>
</OOBE>
<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Name>Vantium</Name>
<Group>Administrators</Group>
<Password>
<Value>XXXXXXX1</Value>
<PlainText>true</PlainText>
</Password>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
</component>
</settings>
</unattend>
Answered 04/06/2011 by: ronellis10
Senior Yellow Belt

Please log in to comment
0
Still getting an error message but this one is different than before.

Windows could not parse or process unattend answer file [C:\Windows\Panther\unattend.xml] for pass [specialize]. A component or non-list setting is specified more than once in the answer file.

My answer file is above in my previous reply.
Answered 04/07/2011 by: ronellis10
Senior Yellow Belt

Please log in to comment
0
I found the answer to my issue in another thread. http://itninja.com/question/semi-unattended-answer-file
This resolved my issue and everything is working as expected now.
Answered 04/07/2011 by: ronellis10
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share