I am trying to modify my Windows 7 unattend to turn off UAC on first login, has anyone got an example of this that they know works. I have tried several things, so far no luck. Thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
You can use a script and the RunOnce key for this. You can also modify local security policy (not sure if this can be done prior to sealing an image for unattended deployment) or use Group Policy to do it for you.
Answered 04/20/2010 by: airwolf
Tenth Degree Black Belt

Please log in to comment
0
Since you are using an unattended installation I guess you are using an answer (xml) file for your settings.
Add component “x86_Microsoft-Windows-LUA-Settings_6.1.x” to your answer file and sett EnableLUA to false.
Answered 04/21/2010 by: jahnemar
Senior Yellow Belt

Please log in to comment
0
I have found several versions of XML stuff that will turn UAC off but they all return errors during install. I am sure it's possible that my syntax is off, if someone could post an example script I would really appreciate it. I need UAC off to run a postinstall task that renames and joins domain. Thanks
Answered 04/21/2010 by: jmprnbr1
Senior Yellow Belt

Please log in to comment
0
The easiest way is to do this in “Windows System Image Manager” that’s included with WAIK. It’s also possible to validate your answer file from the same application, but if you want to edit the xml file then add this to the end of file, but before the line with "</unattend>".

<settings pass="offlineServicing">
<component name="Microsoft-Windows-LUA-Settings" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<EnableLUA>false</EnableLUA>
</component>
</settings>
Answered 04/22/2010 by: jahnemar
Senior Yellow Belt

Please log in to comment
0
That worked PERFECTLY, got me where we needed to go. Thanks a million.
Answered 04/23/2010 by: jmprnbr1
Senior Yellow Belt

Please log in to comment
0
Could I change just the processorArchitecture info to make this apply to 64?
Answered 04/30/2010 by: jmprnbr1
Senior Yellow Belt

Please log in to comment
0
I have not deployed x64 version of Windows 7, but the only difference I can see is this: processorArchitecture="amd64".
Answered 05/03/2010 by: jahnemar
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity