I'm having difficulty connecting to the k1000 mysql database. I'm following the directions specified here: http://www.kace.com/support/resources/kb/article/Can-I-access-the-K1000-appliance-database-using  . I changed the password under "Settings>Control Panel>General Settings>Update Reporting User Password". I made sure the "Enable Database Access" checkbox was checked under "Settings>Control Panel>Security Settings". My connection settings and the error I get when I try to test them look like this:

I'm guessing that somehow I'm doing something stupid, and that this should be very simple... Any ideas?


Answer Summary:
Changing the password didn't work for whatever reason.
0 Comments   [ + ] Show Comments


Please log in to comment


This content is currently hidden from public view.
Reason: Removed by user request
For more information, visit our FAQ's.


See if part 7 of this post helps:



Answered 06/22/2012 by: jverbosk
Red Belt

Please log in to comment

I ended up getting this to work. The problem? The K1000 was still using the default password for the MYSQL DB despite the fact I changed it... twice. I changed the password using the text box here "Settings>Control Panel>General Settings>Update Reporting User Password", but it still was using the original password. Mostly because I'm curious, has anyone else experienced this? Since its working I'm not to concerned about it, but I'm a little puzzled.


Answered 06/22/2012 by: Ben M
Ninth Degree Black Belt

  • Hi Ben M,

    You should be able to change the default password for R1, please feel free to file a support ticket so that we may resolve this issue for you.
Please log in to comment
Answer this question or Comment on this question for clarity