We just moved to a K1000 VM from a previous physical K1000 appliance.  Our issue is the machines are not checking into the VM, it hasnt been very long, but we are wondering if we are missing something? The agents are 6.4.522. and the appliance version is 6.4.120756, thanks!
6 Comments   [ + ] Show Comments

Comments

  • Hey, I did the same thing about 3 months ago. One of the things you have to be sure of is make sure that the servers were named the exact same and have the same IP address. I'm sure you probably did that, but I figured just in case.
  • Thanks, yeah the VM is using the same IP and name
  • Have you:

    1. checked the amp.conf file on a machine that isn't checking in?
    2. try to ping your new server from a machine that isn't checking
    3. add your new machine name and ip address to the hosts file on a machine not checking in. If it does after you do this, then it is a DNS issue
  • Thanks for the suggestions!

    1. Checked the amp.conf file, not sure what i should check..but it's on there.
    2. Could not ping the new server from a machine that isn't checking in.
    3. Added the new machine name and ip address to the hosts file, but still not checking in.
  • You want to make sure the amp.conf file has the FDQN name. Also in your KBOX network settings, make sure you are using the same name as you are in the amp.conf file for the webserver name field for Network Settings.

    if you can't ping the box via name or IP, then it has to be a networking issues and not a KBOX issues. You may have to check your VM settings...etc

    if you added the name of your KBOX (Fully qualified name) and IP and still not checking in, then dns resolution is an issue. Check the Network settings as i mentioned to make sure the web server name field is fully qualified. not a short name like k1000 but instead k1000.yourdomain.com...etc
  • Not sure if this will resolve your issue, but I have had a similar issue recently and completed the steps to resolve the problem:

    - Select Settings --> Control Panel --> Agent Settings
    - Turn SSL OFF.
    - Click on Save and Restart Services
    - Turn SSL ON
    - Save and restart Services

    If you don't use SSL, I would try turning it on, saving and restarting the services and then turning it back off and saving and restarting the services.

    Good luck.
Please log in to comment

Answers

1
- Select Settings --> Control Panel --> Agent Settings
- Turn SSL OFF. 
- Click on Save and Restart Services
- Turn SSL ON
- Save and restart Services

If you don't use SSL, I would try turning it on, saving and restarting the services and then turning it back off and saving and restarting the services
Answered 07/28/2016 by: OstwaldIT
Senior White Belt

Please log in to comment
Answer this question or Comment on this question for clarity