anyone can help me to resolve this issue wfcrun32 ERROR-Failed to set Event Logging. I have encounter this after installing the msi using system context in windows7. Citrix online plug-in (Web)12.0.06410
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
0
Try this link here

If you exhaust all of those options, come back with what you have already tried to resolve the issue and the board will see if they can assist further.

Thanks,

Dunnpy
Answered 06/24/2010 by: dunnpy
Red Belt

Please log in to comment
0
Thanks dunnpy,

i have already visited the link that you [provide. Im currently using windows7, after i have done my package and itry to installation the application the error prompts i just want to knowif there is a process to terminate the error. please advise

BR,
gibo
Answered 06/24/2010 by: gibo
Senior Yellow Belt

Please log in to comment
0
Are you using an appsrv.ini with your deployment?
Is there a LogFileWin32 path specified in it?

It seems to me that the error is still related to the CTX118553 article, in that it deals with event logging and the user profile paths.
And the fact that the system context may not be able to access some path.

This Blog has an additional step that was taken on a virtual desktop. It's going to be something around the CTX fix to resolve it.

You don't say if this occurs when you manually install the software, or just when installing in a system context.
What steps have you already tried? What if the log file path was not located in the user profile?
If you create a verbose log of your MSI installation does that throw any further light on it?

Thanks,

Dunnpy
Answered 06/24/2010 by: dunnpy
Red Belt

Please log in to comment
0
Hello all.

I have the same problem with installation of this plugin in a system context (Win 7)...

If you create a verbose log of your MSI installation does that throw any further light on it?

verbose log says that application was installed successfully. I cannot find any error/warning messages in it.

Any ideas how to solve this issue?
Answered 07/07/2010 by: krulik
Senior Yellow Belt

Please log in to comment
0
I forgot to say that error appears only if UAC is enabled.
Answered 07/07/2010 by: krulik
Senior Yellow Belt

Please log in to comment
0

Hi,

UAC (User Access Control list) blocks the execution on any exe from package in Win7.
We should be aware that exe execution would be blocked if UAC is on in the user mode. Necessary work around should be taken care (Active Setup also should be taken care).

I have registry tweak to Enable / Disable the UAC.
Registry key to suppress the UAC
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System
EnableLUA = 0 (REG_DWORD)
ConsentPromptBehaviorAdmin = 0 (REG_DWORD)
Registry key to enable the UAC
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System
EnableLUA = 1 (REG_DWORD)
ConsentPromptBehaviorAdmin = 5 (REG_DWORD)
It is purely your choice how you use the above tweak(not suggestible).
Also we have option to suppress the UAC in Wise Package Studio 8 if you are calling any exe from msi.

May be this piece of info will work for you..

Thanks
Answered 08/06/2010 by: win7packager
Senior Yellow Belt

Please log in to comment
0
For Citrix online plug-in 12.1.44 I used the following...

DONOTSTARTCC=1. Prevents Connection Center Service from starting during installation. Citrix recommends using this parameter when deploying the online plug-in using Active Directory, GPO, SCCM, LANDesk, Altiris and Citrix Receiver.

Setting DONOTSTARTCC=1 will also prevent the following error

"WFCRUN32 Error - Failed to set Event Logging"

Here are the articles about this error.
http://support.citrix.com/article/CTX126950
http://forums.citrix.com/thread.jspa?threadID=88181&start=0&tstart=0

Command Line switches from Citrix
http://support.citrix.com/proddocs/topic/online-plugin-120-windows/ica-configure-command-line.html
Answered 08/26/2011 by: mreusguy
Senior Yellow Belt

Please log in to comment
0
I am new to this forums........
Answered 10/04/2011 by: nila
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity