I have been having a peculiar problem with Quicktime when creating an AIP. I have not encountered this issue when creating an AIP from any other vendor's product. When creating an AIP I always create on the local box by specifying TARGETDIR=C:\"productname" Once the AIP is created I then move it to the desired network location. When I do this with Quicktime the file QTJava.zip will always be installed to whatever folder I had originally specified when creating the AIP. For example, if I had specified my TARGETDIR=C:\qt during the AIP creation the QTJava.zip will get installed during normal installation to C:\qt\Program Files\Quicktime\QTSystem\QTJava.zip. All other files will get installed correctly to C:\Program Files\Quicktime. Another example, if I had specified my TARGETDIR=C:\Program Files during the AIP creation, the QTJava.zip will get installed during normal installation to C:\Program Files\Quicktime\Program Files\QuickTime\QTSystem\QTJava.zip.

Note: I do NOT specify TARGETDIR during a normal install. Only when creating the original AIP.

I have done a comparison of the original msi and the one created in the AIP using MSIDiff. The only differences are "LastAuthor", LastPrinted", and "SourceType"

I cannot figure out where or how the installer is getting the original TARGETDIR information during a normal install.

Anyone have any ideas as to why this is happening besides QT being a poorly authored installer?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Maybe creating verbose log during AIP will trace the AIP issue. Or please attached the AIP log file so that I can help to trace the problem.
Answered 12/10/2010 by: Rameioj
Senior Yellow Belt

Please log in to comment
0
The problem is in creating the AIP. It's the installation from the created AIP. Looking at the logs I noticed a property being set during installation QTJAVA=C:\qt\Program Files\\Progam Files\QuickTime\QTSystem\

I tried setting the QTJAVA property to C:\Program Files\QuickTime but it is just getting overwritten during install. This is really a puzzle. The only workaround I am aware of now is to not specify TARGETDIR during the creation of the AIP. Problem is it dumps all the files and folders at the root.
Answered 12/10/2010 by: joedown
Second Degree Brown Belt

Please log in to comment
0
Set the property QTJAVADIR using a custom action instead of in the property table. That should do the trick for you.
Answered 12/10/2010 by: michaelnowell
Second Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity