Hi everybody! I'm new to this website (even though I've been a packager over a year!) but the time of desperation has come to me [:(]

I'm trying to do a silent install of Websense Client 7.6. It's basically and a setup.exe wich gets some configuration settings from a HSW file and then calls an MSI. No matter what I've tried, the install always display the UI, despite the fact that the setup.exe is supposed to include /S and /V switches (if you type "setup.exe ?" on cmd, it tells you that to do a silent install you should use /S/v/qn, but unfortunately it only hides the executable part of the UI, the msi UI is still there, including the license agreement)

Here's what I've tried:
- Creating a transform that adds LIMITUI=1; ARPNOMODIFY=1 and AGREETOLICENSE=Yes
- Adding quotes to all the msiexec commands (like setup.exe /S /V"TRANSFORMS=TransformPathAndName /qn")
- Capturing the response file when creating the transform

None of the above has given me any result, that darned UI keeps showing.

Since that *.hsw contains some configuration specific for the client, I must use the setup.exe to get those settings into the configuration, so trying to use the msi alone will not do the trick. Also, since this software is supposed to be an internet use monitor and filter, it should ask for a password on unninstall, so repackaging it does not sound like a good idea (I believe it could strip the package from the uninstall intelligence, but if I'm wrong, please correct me.)

Any idea will be greately appreciated, and if you ever come to Mexico city, I can offer in exchange an awsome beer and some delicious (and fat-filled) meal [;)]
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
It sounds like your /QN isn't being passed to the commandline of msiexec - enable MSI logging to check that it is - see here.

When using the /V switch you have exclude any spaces before your first msiexec parameter:

Setup.exe (space) /S (space) /V(nospace)/QN = Setup.exe /S /V/QN

Hope that helps,

Dunnpy
Answered 08/08/2011 by: dunnpy
Red Belt

Please log in to comment
2
Fix:

Open the Setup.ini and enter /qn in the cmdline option:

[Info]
Name=INTL
Version=1.00.000
DiskSpace=8000 ;DiskSpace requirement in KB

[Startup]
CmdLine=/qn
SuppressWrongOS=Y
ScriptDriven=0
ScriptVer=1.0.0.1
DotNetOptionalInstallIfSilent=N


Then pass /S to setup.exe and you should be good.
Answered 08/08/2011 by: trance23x
Yellow Belt

Please log in to comment
0
Dunnpy
- Thank you for the reply, but it seems that spacing was not the catch here, it kept ignoring everything after the /v regardless of the spacing.

trance23x
- Great! Indeed that ini file was there and now all the msiexec commands are being taken (including adding a transform). I feel dumb for not noticing that ini file before... Thank you! What would it be? Indio or Corona? [8D]
Answered 08/08/2011 by: apopompi
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity