Has anyone managed to get Wake on Lan working with a UEFI BIOS ? 

I have a Dell Optiplex 9020 that arrived with Windows 8 installed with a UEFI BIOS and I cannot get WOL to work from the K1000. All of the other 9020's that have Windows 7 installed run a legacy BIOS and they all work fine with WOL.

10 Comments   [ + ] Show Comments

Comments

  • will it wake and not boot or just ignore the command all together
  • No, it won't wake at all, the lights on the NIC are on when powered off so it should wake up
  • see if the bios version is different between the w7 and w8 machine. Also have you tried to switch the bios on a win7 to uefi and see if it will wake. It will not OS boot but will tell you if the wol is working on those in UEFI.
  • I have tried changing the BIOS version to match the Win 7 machine, still no go. I will change a win 7 to UEFI if I can find one where someone is away and will let you know
  • Ok ... tried that and when set to UEFI it does not wake up but it does when changed back to BIOS. So obviously an issue with the UEFI implementation
  • If they all have the same version of bios I would contact dell on that, may be a bug in that bios that blocks it. You may have to back rev the bios even to get it to work, I see they list a current and 5 older versions for that model.
  • Yeah .. I have already back rev'd the BIOS to the same as the Win 7 machine, I'll put a call into Dell and see what they say
  • we do not have any 9020's yet just 9010's so I can't play with one myself to see
  • Does it work on the 9010's with UEFI ?
  • I just fought this with Optiplex 7040 and Latitude E6540. Make sure that "fast startup" is turned off in your Power Options.

    1. Control Panel
    2. Power Options
    3. Choose what the power buttons so (left margin)
    4. If the options are greyed out, click "Change settings that are currently unavailable" at the top
    5. Uncheck "Turn on fast startup (recommended) and save.
Please log in to comment

Answers

0
What about choosing to "Block Sleep (S3 state)" in the BIOS? Should be a setting for that. BIOS is updated to the latest?
Answered 04/19/2017 by: mikedouglas
Senior White Belt

Please log in to comment
0

This article may help

http://en.community.dell.com/support-forums/desktop/f/3514/t/19434669.aspx

Answered 01/21/2014 by: SMal.tmcc
Red Belt

  • That was already set and still does not work
Please log in to comment
Answer this question or Comment on this question for clarity

Share