Hi!

I have a package created with setupcapture* in Wise Package Studio Std 8.0 and have problem with a shortcut.
The shortcut looks like this:
Target = C:\Windows\System32\cscript.exe "C:\Program Files\%MY_app%\%my_app%.vbs" %myapp%.exe
and Start in = "C:\Program Files\%MY APP%"
In the instruction for the shortcut I shall check "Run as administrator" in the "Shortcut-tab" and "Advanced..." button.
During the capture I copied a prepared shortcut to the all-users profiles startmenu.
When I install the MSI the "Run as administrator" on the shortcut is unchecked.

I have not been able to check the "Run as administrator" within the MSI.. Do you have any recommendations?

*The capture also includes running a installationprogram, copying a folder to C:\Program Files\ and "regsvr32" two files in the folder I copied.

I´m currently trying to move the functions from the vbs to the package and go directly to the exe-file:
1. Add two folders to the path
2. Create one folder in the users appdata folder and one in the users tempfolder.

I also tried to use "AppCompatFlags" and set RUNASADMIN on exe, vbs and shortcut-file, it only works when logged on as an administrator. When logged on as user before adding "AppCompatFlags" the application crashed, now with "AppCompatFlags" nothing happnes, and nothing is written to the application log in event viewer.

Regards
Mackan
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
The only reason I can think of that an application might need administrator rights when it runs - other than incredibly dumb programming by the developer - is that it writes to protected areas, either a file or registry data. If that's the case, you should alter your package so that it either includes the file/registry data that gets written or, if that data is dynamic, you should include entries in the LockPermissions table to allow access or, better, use a Custom Action to permission the relevant area.
Answered 06/21/2011 by: VBScab
Red Belt

Please log in to comment
0
Tnx for quick answer [:)]
I agree with you on "incredibly dumb programming by the developer".
I already used a Custom Action with secedit to open the applications program files folder, will try with some in the registry now. When running the shortcut I only get to a logon-dialog...

I´ll let u know how it works out

/Mackan
Answered 06/21/2011 by: Mackan75
Orange Belt

Please log in to comment
0
What VBSCab meant was capture the entries after executing the shortcut and add all those entries to your msi(make sure that data is not dynamic as VBScab said). And also use procmon when running the shortcut and check to which files and regetries you need to give permission.
Answered 06/21/2011 by: naveen.packager
Green Belt

Please log in to comment
0
Jupp, I got that, tnx :)
Answered 06/21/2011 by: Mackan75
Orange Belt

Please log in to comment
0
Answered 06/21/2011 by: AngelD
Red Belt

Please log in to comment
0
It is solved in a very ugly way ...
Removed shortcut created in the WPS and added a lnk file with the setting checked as a file in the All Users Start Menu ...
A group policy kicked in and complained about the vbs file, double click the exe file got the same results ... Unfortunately, this was solved by making users into administrators. :(

/Mackan
Answered 06/29/2011 by: Mackan75
Orange Belt

Please log in to comment
1
Check out the workaround at http://itninja.com/question/silent-uninstall-oracle-8-cilent8366
Maybe not the best workaround but still ;)
Answered 06/29/2011 by: AngelD
Red Belt

Please log in to comment
0
AngelD
Thanks for the tip, it didn´t work :(, possibly because the dislike cscript kicks off with arguments. Tested to have the argument both on the command line and the "Add arguments" and "Start in". However, the hint may be useful at another time :)

/Mackan
Answered 06/30/2011 by: Mackan75
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity