Hi,

I used the original MSI from MS for my VisioView deployment.

When I run msiexec/i package.msi /qb I get "The EULA has not been accepted" So I used ORCA and added "ACCEPTEULA" w Value 1 in the Property table.

I still get the same error message, I also added ASSOCIATE 1 in a desperate attempt, no change..

I can't use the setup parameter as shown on appdeploy, I don't know how, unless you distribute the package via SMS??

Any ideas?

Thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
0
You can set public properties (those identified in all CAPS) at the command line along with your other switches:

msiexec /i package.msi ACCEPTEULA=1 /qb
Answered 02/16/2004 by: bkelly
Red Belt

Please log in to comment
0
Yes, and that works - when I run the package from the command line. But how do I apply this to a .MSI package that is supposed to be distributed via AD GPO only? Is there anyway to add parameters to an existing MSI package in a software policy? Or am I missing the point completley? [&:]
Answered 02/16/2004 by: Archimonde
Senior Yellow Belt

Please log in to comment
0
To assign this property a value in a GPO deployment, I would create an MST (Transform) and create and assign this property to it. Then in the Advanced deployment properties you can use the "modifications" tab to specify the MST file. I believe the Microsoft Office Custom Installation Wizard (CIW) it the preferred way to generate an MST for Visio. You may still need to edit the resutling MST to add a value for this property after you have created the MST- if you do not see it as an option in the CIW.

Hope this helps.
Answered 02/16/2004 by: bkelly
Red Belt

Please log in to comment
0
I tried to do this, first using WISE, then ORCA. No luck, but I switched to Install Shield and did the EXACT same thing. Worked perfectly at the fist try... [:D]
Answered 02/19/2004 by: Archimonde
Senior Yellow Belt

Please log in to comment
0
You may not be able to modify the vendor's MSI but if you create a transform you should be able to add the property to the Property table and save it. I created a transform using PackageStudio and then added the ACCEPTEULA=1 property. Running the MSI with the transform worked great.
Answered 03/10/2004 by: rsaada
Yellow Belt

Please log in to comment
0
Yes, I did just that this time using ISW and everything worked, case closed [:)]

Thanks anyway!
Answered 03/11/2004 by: Archimonde
Senior Yellow Belt

Please log in to comment
0
Something in InstallShield actually worked? :)
Answered 03/11/2004 by: MSIMaker
Second Degree Black Belt

Please log in to comment
0
I did this with Wise Package Studio 4.62 and 5.1.
All you need to do is open the msi file and go to the Execute Immediate script and go to
the section with Cancel Installation [EULAErrorText] [ConfirmEULA] and Comment that line and the End line out with a "*/". You will also need to do this in any Transforms that you may be using with the msi file.


sswilson
Answered 03/12/2004 by: sswilson
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity