When I try to run visio viewer 2003 after packaging it with ORK, it's keep saying something about "ULA not accepted..."
In the package info, they tell me to add ACCEPTEULA=1 ASSOCIATE=1 in the properties.

Can anyone give me a little more detail on how I can go about packaging Visio 2003 using either Wise or ORK?

Thanks in advance.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Did you make an administrative installation point?
setup.exe /a
Answered 11/11/2005 by: sejacru
Second Degree Blue Belt

Please log in to comment
0
Yo Wise Guy,

This probably isn't one of packaging best practices, but it worked. I modified the vendor .msi. This is what I did using Wise Package Studio 5.6:

Open the .msi with Wise Package Studio
Click on the MSI Script tab
Click on the Execute Immediate tab and rem out the following lines

IF NOT ACCEPTEULA AND NOT IsAdminPackage AND NOT Installed then
Canel Installation [EULACheckErrorText] (ConfirmEULA
End

Try it, it worked for me!!
Answered 11/11/2005 by: urban_diver
Orange Senior Belt

Please log in to comment
0
Hey urban_diver, that worked!
One more thing though, I can't suppress the licence agreement dialog box. Wise won't let me create a .mst to supress that setting.

If I just push the .msi with AD would it install?

Thanks in advance.
Answered 11/11/2005 by: WiseGuyinNewYork
Orange Belt

Please log in to comment
0
REMing out those lines I previous mentioned should take care of that problem. This is the command line I use to launch the installation and works fine msiexec.exe /i vviewer.msi /qb I get no errors
Answered 11/11/2005 by: urban_diver
Orange Senior Belt

Please log in to comment
1
I forgot to mention, this might be the reason why you are having registration problems. If you open up the msi go into Setup Editor, click on Properties. Look for the registration property. If you notice Registration is misspelled. It is spelled Registraton. Hope this helps
Answered 11/11/2005 by: urban_diver
Orange Senior Belt

Please log in to comment
0
I can't get it to work. It only works when I do this;

msiexec.exe /i vviewer.msi /qb-! accepteula=1 associate=1

But how can I use this in AD. I am faily new to this and I can't find any extra settings in group policy where I can add those lines.

Any help is greatly appreciated.
Answered 11/11/2005 by: WiseGuyinNewYork
Orange Belt

Please log in to comment
0
Have you tried hard coding those properties inside the .msi?
Answered 11/11/2005 by: urban_diver
Orange Senior Belt

Please log in to comment
0
I got it going. Based on the knowledgebase, I found the PIDKEY inside the .msi and I created a .mst using ork. Now the isntallation works using Group Policy.

BTW, just out of curiosity how or where can I hard code the information using Wise?

Thanks for all your help.
Answered 11/14/2005 by: WiseGuyinNewYork
Orange Belt

Please log in to comment
0
You can create (hard code) properties in the Setup Editor. Right click on Properties | New | Property
Answered 11/14/2005 by: urban_diver
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity